Segmentation fault

Hi,
I’m struggling a lot with the Calf Fluidsynth plugin so I’m removing it from all my projects.
But there’s one project which crashes at startup due to Fluidsynth:

Lots of:
fluidsynth: warning: No preset found on channel 0 [bank=1 prog=0]
End ending with:
Segmentation fault (core dumped)

I tried starting with disabled plugins but that does not make a difference.
Is there a way to remove the plugin “from the outside”? Or any other method to start a session with Fluidsynth not only disabled but disarmed?

Update1:
I have edited the session file directly and removed the Calf Fluidsynth (Processor id) but Ardour still crashes ending with
Set cursor set to default
Segmentation fault (core dumped)

So now I’m not so shure this crash has something to do with Calf Fluidsynth.
Any suggestions?

Update2
I could open the session with Ardour6, removed all plugins, made a -save as- copy but there is something somewhere that still makes Ardour 7 crash:

Set cursor set to default
protocol Wiimote not found
Segmentation fault (core dumped)

Wiimote??

Ardour comes with Fluidsynth built in, as “ACE Fluidsynth”. I would suggest trying that and see if it works differently/better.

Yes, I was doing that.
I planned to do that in all my sessions but there is still one that I cannot access due to crashing.

The thing now is that i can start it with Ardour6, I have completely removed everything, all tracks except Master. En cleaned/flushed up all. So to me it’s a completely empty session, I’ve cleared all files by hand everything in the interchange directory, plugins directory and Ardour7 keeps crashing on that particular session. Strange. Could there be any settings or files outside the session directory that is preventing Ardour 7 from starting up this particular session?

Are you using the official Ardour 7 binary from http://ardour.org/download.html , something your distro has provided or something you’ve compiled yourself?

Try renaming your ~/.config/ardour7 to ~/.config/ardour7.old before starting the program and see if that helps. Maybe you’ve got some weird stuff in your config files.

I use 7.1.0 official binary, downloaded.
I renamed the config file but it makes no difference.
The thing is that it’s only one project-session that is crashing. All other session have no problem at all.
Ultimately I can recover this project by importing the audio and midifiles in a new project but it is strange that a seemingly empty session keeps crashing.

In similar situations I have seen Robin or Paul request opening a mantis ticket with the session files attached so they can determine what is causing the crash.

After some experimenting, I come to the conclusion that Ardour 7 fails at conversion from 6 to 7
Opening the session with version 6 is no problem. But if I then open that session with 7 it creates a new session file (renames the old one) and crashes. And the new file looks more or less the same as the 6-version. I don’t know where the hiccup might be. I tried step by step to edit the file to make it more 7-ish but it takes too much time and for what I tried it failed.

That’s ok, the reason for attaching session files to the bug report is so that a developer can open the session files while running in a debugger to determine where the conversion faults.

I have posted a bug-report.

I completely emptied the session (imho), and it still fails to convert.
Maybe this is a weird coincidence and a local phenomenon but I’ve got a lot of Ardour6-sessions archived and it would be unpleasent if later on more of these sessions turn out to be not convertable.

Thanks for the reactions/replies.