Segmentation Fault at startup

Hello everyone,

I’m using Kubuntu.

bubu@bubugep:~$ uname -a
Linux bubugep 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
bubu@bubugep:~$ cat /etc/issue
Ubuntu 11.04 \n \l

I’ve installed ardour and jackd from the repo.
Ardour gives segfault at startup.

bubu@bubugep:~$ ardour2 Ardour 2.8.11 (built using 7387 and GCC version 4.5.1) Copyright (C) 1999-2008 Paul Davis Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker Ardour comes with ABSOLUTELY NO WARRANTY not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. This is free software, and you are welcome to redistribute it under certain conditions; see the source for copying conditions. Segmentation fault bubu@bubugep:~$

I don’t experience any other issues with other things, and my system is quite standard, based on Kubuntu repos.
I haven’t find useful infos on this matter, what I tried is ticking a checkbox in jackd regarding DBUS, but it hasn’t helped.

Any suggestions?

Hi ndani,

have you updated raptor recently? There are some problems with newer raptor packages in Debian based distribution.
Otherwise, and unfortunately, you have to ask the maintainer of the Ubuntu Ardour package - they made something wrong with Ardour.


Don’t know if it’s the same issue but i’ve had very unfriendly seg faults with ardour in the past (i think v 3.0) that were caused by irregularities in the main ardour project (xml) file. It took me a couple of days to figure it out but it was due to incomplete region node in the playlist. Once i had it narrowed down, it was obvious which nodes were causing the problem. Come to think of it, i think it was crossfades that didn’t have all the timing parameters defined. Sorry i can’t remember the details. Seems like ardour should do something a bit friendlier if it can’t properly parse the xml, especially since it seems to produce bogus xml in certain circumstances…

BTW, i fixed the problem by duplicating the missing parameters from some of the node’s immediate “neighbors”.

Well, not sure what raptor is, but regarding to synaptic, the only installed package that has the string “raptor” in it is libraptor1, which is v1.4.21-2. Can this cause any problem?

Regarding tophatdave’s comment, if I understand it correctly, it refers to circumstances where Ardour had been working until ‘something’ happened that made it wrong.
I’ve never managed to run Ardour, and it is a virgin installation, that is why I’m thinking this issue is not related to project files.

Hi ndani,

yes, I was referring to libraptor, and you have the same version installed as me (I’m using Debian here), so it should be ok. I had some trouble when I updated that package to a newer one (I think 1.4.22).

So you should report your problem at
since this looks like an exclusive Ubuntu problem and has nothing directly to do with Ardour.

Maybe you can try to remove ardour completely (also the user settings) and make a fresh install.


I have/had the same problem with ardour on kubuntu. It’s some bug in the oxygen-theme of gtk, which is AFAIK the default theme in kubuntu. This bug makes ardour crash, both ardour2 and ardour3. If you sudo to ardour, ardour does not read your users gtk config files and thus does not use the oxygen theme.

So a workaround is, to change the gtk theme. (System Settings -> Look and Feel -> GTK-Look’n’Feel). Be aware of that some themes are not suitable for ardour, because they don’t show the (red green or yellow) lights of the rec, solo or mute buttons. I am using Raleigh which looks alright.

Feel free to copy or rewrite my comment when filing a bug.


I’ve just tried “sudo ardour2” and it has started.
Any clues what can be wrong with starting as a normal user?

One more thing before I go to launchpad.
Syslog says:

Jun 27 08:43:34 bubugep kernel: [14332.976646] ardour-2.8.11[7698]: segfault at 50 ip 00007fb2d4357d1c sp 00007fff8a52fc80 error 4 in[7fb2d4168000+436000]


Hm, maybe something’s wrong with your GTK2 installation. But I don’t have a clue what, sorry!


Thanks for all of the suggestions.
I’ll try at launchpad.

Oh my godness.
It works. Thank you very much.

Oh my goodness, what an embarassing bug in… (now who’s the culprit? U/Kubuntu? version?.. certainly not Ardour itself)!
Cheers to johmue for pointing that one out :slight_smile:

Hopefully we’ll see 3.0 final soon with universal builds, so that such problems will go away - donate people!