Segfault in fedora 14 error 4 in libc


I have build the svn of 2-ongoing today on Fedora 14 and it crashes like this:

Loading ui configuration file /usr/local/etc/ardour2/ardour2_ui_dark.rc
theme_init() called from internal clearlooks engine
ardour: [INFO]: Ardour will be limited to 1024 open files
loading system configuration file /usr/local/etc/ardour2/ardour_system.rc
ardour: [INFO]: Using SSE optimized routines
Speicherzugriffsfehler (Speicherabzug geschrieben)

Last line in English: segmentation fault (core dumped)

reading /var/log/messages reveals this:

Dec 16 15:32:35 denkpad kernel: [ 145.306261] ardour-2.8.11[2445]: segfault at 8 ip 0131f056 sp bffd71d4 error 4 in[129e000+18d000]

is there anything I can do?

@zettberlin: this is likely caused by an issue that involves libxml2 and zlib. It came up in Ubuntu a week or two ago, and there’s no reason not to expect it elsewhere. There are no changes in Ardour involved - libxml2 is apparently using zlib “wrong” in the new versions of one or both libraries. There are quite a few references to it online, here’s one:

Thanks for the info!

Do you think, down/upgrading libxml2 from source could do any good?

4h later

Upgrading libxml2 from Fedora14 to 2.7.8 from source plus rebuilding ArdourSVN did not do the trick.


Neither upgrading to the dayly git from nor downgrading to 2.7.6 did help.

What really disturbs me is, that I actually had the Ardour from the Fedora-package running with quite okayish results two days ago after F14s fresh install…

I am about to give in on that and try pure:dyne or OpenSuse. But if it is an issue with libxml2 it seems likely, that the same trouble will await in these distros too.

Anyone else out there with the same problem (and maybe a workaround)… (a solution even?)?


Is supposed to be solved with libxml2 2.7.7 witch is the version installed in Fedora14.

Ardour did work flawlessly 3 days ago on my fedora14.

So the situation is, that I am absolutely clueless about what is going on here.

Hello, everybody!

hope you had nice holydays :slight_smile:

I now run the ccrma-rt-kernel and upgraded Fedora and the svn-builds of Ardour 2 and 3 yet to no avail. Same situation…

I am not really sure wheather to file a bug-report on the issue or not…

@zettberlin: this is NOT an ardour error. Its a problem with your distributions packaged versions of libxml2 and zlib. its not possible for us to comment definitively on how to solve this on a distribution-by-distribution basis. There is absolutely nothing that we can do with Ardour to correct this issue (and Ardour is not the only program affected). You need to seek help on Fedora forums, not here.

You need to seek help on Fedora forums

I did.

They recommended downgrading. I also found a rather crude tutorial on how to downgrade glibc, xml2 and zlib to make vmware-player run, that seems to have the same problem.

Since I do not think, that downgrading can be an option in the long run, I’ll try the git-snapshot of libxml2 whenever it is upgraded at

Do I need to rebuild Ardour too to get the effect once the problem is solved in libxml2?

@zettberlin: no, the problem will just go aware magically once libxml2 and zlib play nicely with each other. no rebuilds of any software is required.

Thanks again :slight_smile: Good to know this.

Now I see some improvement. Running strace revealed, that the segfault appeared, as Ardour reads (LADSPA). Removing this lib allows Ardour2 and 3 to start and run.

Still not all is well, Ardour runs in English, the locale is ignored.

I will keep watching this matter, in a much more relaxed mood however :wink:

Thanks for the clarification on this.