second try

Dear Forum,

For quite some time I have tried but not yet succeeded to enter Linux audio recording with Ubuntu Studio and a Tascam us122. As you can see here ( I finally went back to reinstalling my us122 (after reinstalling the entire OS to wipe all the traces of my configuration attempts). According to gMaqs suggestions I just installed the packages from ematech. However my interface would not turn on when I plug it.

lsusb gets me
Bus 002 Device 002: ID 1604:8006 Tascam US-122 Audio/Midi Interface (without fw)
I dont know whether the “without f(irm)w(are)”-remark is of importance.

If I start usx2yloader in a termnal I get
usx2yloader: no US-X2Y-compatible cards found

Googling for this I found the following guidelines:
I remember that last time this made things work, but I could only access one of the two mixer channels of the interface and I also feared that my inability to access it with jack/ardour might have stemmed from this hand-tuning. Gmaq on the other hand seemed to have implied that I could get the device started much more easily.

Any ideas? Otherwise I fear I will be stuck with Windows98 and Logic Audio 5.5 forever, when it comes to recording.

I have no experience with the us122 but from reading the ALSA page ( and this ( I guess you must make sure the firmware is loaded, either automatically through the 55-tascam.rules or manually (if you follow the 224 page)

Thanks. I read these pages but hesitate to set up my system accordingly because Gmaq (in the other thread I referred to) suggested that the procedure of installing the us122 has changed, and there are many outdated howtos out there. I had indeed consulted these pages and a few more last time, too, and done what they say, but the device never fully worked.

This time I installed the latest ematech-packages (alsa firmware and alsa firmware loaders) and dont want to mess with their default configuration unless I know what I am doing. One problem I can see is that these packages set up a udev-rule that tries to load the file “ld2-ezusb.hex”. But this file is not anywhere on my system. In the alternative udev-rules I see on the page you mentioned this file is not loaded. There they load “tascam-loader.ihx”, which I have on my system. But if I just replace this file for the other in the udev-rules still the tascam does not get activated when I plug it. Typing the original udev-rule manually to the console I get a “no such directory” error. But the directories exist and the required files (except for the ld2-ezusb.hex) are there.

This is my original 55-usx2yloader.rules as it is created by the ematech package. Only the third line applies.

BUS==“usb”, ACTION==“add”, SYSFS{idProduct}==“8000”, SYSFS{idVendor}==“1604”, RUN+="/bin/sh -c ‘/sbin/fxload -D %N -s /lib/firmware/usx2yloader/ld2-ezusb.hex -I /lib/firmware/usx2yloader/us428fw.ihx’"
BUS==“usb”, ACTION==“add”, SYSFS{idProduct}==“8001”, SYSFS{idVendor}==“1604”, RUN+="/bin/sh -c ‘/usr/bin/usx2yloader; /usr/bin/us428control -m mixxx&’"
BUS==“usb”, ACTION==“add”, SYSFS{idProduct}==“8006”, SYSFS{idVendor}==“1604”, RUN+="/bin/sh -c ‘/sbin/fxload -D %N -s /lib/firmware/usx2yloader/ld2-ezusb.hex -I /lib/firmware/usx2yloader/us122fw.ihx’"
BUS==“usb”, ACTION==“add”, SYSFS{idProduct}==“8007”, SYSFS{idVendor}==“1604”, RUN+="/bin/sh -c ‘/usr/bin/usx2yloader’"

I am close to burying my attempts at Linux audio. Sigh.


Did you type “/sbin/fxload -D %N -s /lib/firmware/usx2yloader/ld2-ezusb.hex -I /lib/firmware/usx2yloader/us122fw.ihx” ? `Cause the %N should be replaced with whatever bus/device it’s attached to (see the “Setting up your US-224 manually” in the page) and that might perhaps explain why you got the “no such directory”.

(This below is basically following the Tascam_US-224 page)

  • Start by moving any tascam-55 and/or 55-usx2yloader.rules from the udev folder to someplace safe (like /root) and reboot. This to make sure you don’t have any faulty setting that interferes.
  • Make sure you’re in a terminal as root.
  • Get the latest firmware (wget and unpack it to, say, /tmp (tar -xjf alsa-firmware-1.0.17.tar.bz2 -C /tmp)
  • Make sure you have the driver loaded (modprobe snd-usb-usx2y)
  • Connect the card and run lsusb to see which bus/device it’s attached to
  • Run fxload -s /tmp/alsa-firmware-1.0.17/usx2yloader/tascam_loader.ihx -I /tmp/alsa-firmware-1.0.17/usx2yloader/us122fw.ihx -D /proc/bus/usb/(whatever bus)/(whatever device)
  • Run lsusb again to verify the fw is loaded
  • Run usx2yloader

This should get you up and running. If not, please report any errors

You are my man! I never understood what %N meant. I just have to add that in Ubuntu Gutsy and later I need to replace the “proc” directory with “dev”.

So the tascam is up and running, though eventually by the same configuration process as last time. Hope the errors will have disappeared nevertheless. Thank you for your help.