scons fails on openSuse 11.1RC1

I’ve tried building ardor3 fom svn, ardour2.0-ongoing and 2.7 with scons 1.0.0, 1.1.0 and 0.98.5 and with gcc-4.3.2 and 4.2.4.
I’ve tried with jackdmp from svn and 0.115.6.
No matter what, scons tells me:

Checking for fftw3f…yes
Checking for fftw3…yes
Checking for aubio…yes
Checking for C header file fftw3.h… yes
FREESOUND support is not enabled. Build with ‘scons FREESOUND=1’ to enable.
Checking for slv2… no
LV2 support is not enabled (SLV2 not found or older than 0.6.0)
Congratulations, you have a functioning C++ compiler.
system triple: i686-pc-linux-gnu

detected DIST_TARGET = i686

Checking for C header file fftw3.h… no

You do not have the FFTW single-precision development package installed.
This prevents Ardour from using the Rubberband library for timestretching
and pitchshifting. It will fall back on SoundTouch for timestretch, and
pitchshifting will not be available.

Checking for usb_interrupt_write() in C library usb… no
Checking for C header file linux/input.h… yes
Checking for C++ header file boost/shared_ptr.hpp… yes
Checking for lo_server_new() in C library lo… yes
Checking for dmalloc_shutdown() in C library dmallocth… no
Checking for C header file alsa/asoundlib.h… no
Checking for C header file jack/midiport.h… no
Checking for C header file alsa/asoundlib.h… no
Checking for C header file /System/Library/Frameworks/CoreMIDI.framework/Headers/CoreMIDI.h… no
It appears you don’t have the required MIDI libraries installed. For Linux this means you are missing the development package for ALSA libraries.

I have alsa-1.0.18-8.4 and the -devel packages installed and /usr/local/include/jack/midiport.h in place

The problem seems to be that when looking at config.log I see:

gcc -o .sconf_temp/conftest_26.o -c - O 3 " " - f o m i t - f r a m e - p o i n
t e r " " - f f a s t - m a t h " " - f s t r e n g t h - r e d u c e " " - p
i p e " " - D A R C H _ X 8 6 " " - m m m x " " - m a r c h = i 6 8 6 " " - m s
s e " " - m f p m a t h = s s e " " - D U S E _ X M M I N T R I N " " - D B U
I L D _ S S E _ O P T I M I Z A T I O N S - W a l l - D H A V E _ L I B L O -I.
gcc: O: No such file or directory
gcc: 3: No such file or directory
gcc: : No such file or directory
gcc: f: No such file or directory
gcc: o: No such file or directory
gcc: m: No such file or directory
…and so on when it tries to check for alsa/asoundlib.h, fftw3.h and jack/midiport.h

I have a vage hunch that I’ve had this problem many years ago but I can’t remember what the culprit was.

Anyone got any idea?

you need a different version of scons and/or python. this is caused by some strange interaction between the two of them. it may be triggered by something in our scons files, but it used to work OK and it works OK in the very latest scons from

I guess it’s another version of python then, since I’ve tried 3 scons versions (and I know 0.98.5 works on openSUSE 11.0)
Forgot to mention these warnings in the begining of the scons run:

SCons.Script:18: DeprecationWarning: the sets module is deprecated
/usr/lib/python2.6/site-packages/SCons/Platform/ DeprecationWarning: The popen2 module is deprecated. Use the subprocess module.
import popen2
/usr/lib/python2.6/site-packages/SCons/Tool/ DeprecationWarning: the md5 module is deprecated; use hashlib instead
import md5
Perhaps they have something to do with it.

But I’ll try compiling another python version tomorrow, 11.1 uses python-2.6.0-2.13, fwiw.

The combo python-2.5.2/scons-1.1.0 worked.

python-2.5.2/scons-1.0.1 didn’t and python-2.6 doesn’t seem to work with any scons.
And 2.5.2/1.1.0 didn’t produce the warning about md5/hashlib and popen2