Scons Build Failure


Whilst trying to build Ardour 2.8.7 from source, I get the following error from scons:

/usr/bin/ld: /usr/local/lib/libfftw3.a(mapflags.o): relocation R_X86_64_32 against `.rodata’ can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libfftw3.a: could not read symbols: Bad value
collect2: ld returned 1 exit status

I have installed and compiled fftw3 with both options as per the instructions. Fail. I then uninstalled them and installed the fftw3-dev package in synaptic. Both options seem to generate the same error - any ideas?



@ak65: your FFTW3 libraries have been built to include the static versions. You can’t use these on an x86_64 (64 bit) system. You need the shared library version(s).

Paul, thanks for your reply.

I’ll look for the shared library versions when I get back to my home daw.

64 bit a mistake? Should I fall back to the tried and trusted i386 version?

Thanks. I got past the fftw obstacle by compiling fftw3 with a -pic option.

Next obstacle: g++ complaining about syntax errors in Onset.h

In file included from libs/vamp-plugins/plugins.cpp:44:
libs/vamp-plugins/Onset.h:21:25: error: aubio/aubio.h: No such file or directory
In file included from libs/vamp-plugins/plugins.cpp:44:
libs/vamp-plugins/Onset.h:56: error: ISO C++ forbids declaration of ‘fvec_t’ with no type
libs/vamp-plugins/Onset.h:56: error: expected ‘;’ before ‘*’ token

Help! Just a little…To my very limited experience in coding eye it looks like either I have the wrong c++ compiler installed, or I am missing extensions or libraries of some sort? These look like syntax errors…I doubt very much it’s a problem with the ardour code…

AK65: no lots of us (including me) use 64 bit.

@AK65: you need aubio these days, and alas our existing SCons build scripts don’t enforce that requirement. It is mentioned on the building page (

@paul: Thanks for the heads up… the good news is that I managed to build and install 2.8.7 :smiley:

I had to compile fftw with a -pic option and then after installing aubio, scripts went ahead with no more errors!

The bad news is that the import audio ‘bug’ is still there as I described in the ‘timesync’ thread. As you say, this is (mostly) fixed in 2.8.8 I’ll check it when 2.8.8 is released.

Not a big deal, just can’t do a “multiple select audio files > process all” type import. Must import the files one by one. Oh, and also by the way, ardour crashes randomly when doing a multiple file import…from total freeze to a disappearing act.

Should I file these issues as bugs in the mantis system?

Sorry if I gravedig this thread, I’m having the same issues from the fftw3 packages because I’m also running a ubuntu64 system…
I googled a lot to know how to recompile with -fpic but I don’t understand quite well which commands should I run…

So my question is: where should I put the -fpic command? I tried putting it in ./configure or make but it’s not a their command.

./configure --help is your friend.
Try ./configure --enable-shared --with-pic --any-other-thing-you’d-like

thanks it worked out :slight_smile: