Scarlett 2i2 and Windows

Hi, does anyone have experience of using Ardour with Focusrite Scarlett 2i2 (2nd Gen.) on Windows 10?

Ardour recognises it’s there and I can select it for output and input when starting up. It seems to record but I can’t hear anything through my headphones (don’t have monitors), neither while recording or when playing back afterwards. I haven’t done anything else to setup the interface with Ardour, so wondering if there’s something else I need to do?

The interface works ok with other software.

I have an outdated Tascam USB unit like the Scarlett.

I change in Windows that to the default play / record device and use my headphones through the device. ie Scarlett.

I use ASIO4ALL for Ardour on windows…
It works similar to JACK (not really)…but its so Ardour understands which sound device to pipe through… it just sits in the system tray and tells you which possible devices are available.
you select one and then shut down any program using another sound device. Restart them in a sensible order… ASIO4ALL launches when Ardour launches (opens a song that requires to grab the sound device you prescribed)

For Me i use Voicemeter. This Allows me not to use my old Tascam and instead run system sounds through its Virtual Input… i run Ardour on the Aux Virtual. so when you look at the master outs… it shows 8 output.


If you changed the sound card you were using and didnt change it in windows or changed it while Ardour was still running… it will still show the devices as being there but …everything has to be disconnected from the windows audio … in order to make the changes to which device does what.

Then when Ardour launches it grabs that device to try and use as a sound server / output.

Same For ASIO4ALL … but it has to be changed while Ardour is up or another device is using it … changed and then everything restarted.

i did not need to reboot but you can restart the audio in Windows before connecting and running again to be on the safe side.

IF you just loaded the driver for the Scarlett … you may want to reboot… and make sure you have the latest drivers for windows etc.

Thanks for that. I tried Asio4all, and although my problem is still there I now understand that the problem is that another software seems to be using the interface, so at least closer to a solution. The question is how I find out which, so I can close it. There’s no obvious software running that would be using it that I can see.

Did you install the Focusrite Scarlett MixControl ? If not install it, it might fix your problem. If the Focusrite is Standard windows output either disable windows sounds or even better make some internal sound card the standard interface, so no program wil use the focusrite unless you want it
I have a 18i20 and I records Live some 18 tracks and after that some 5 6 tracks extra on a small PC and it works like a dream.

Good luck