Samson C01U output level problems


I just replaced my Logitech USB desk microphone with a Samson C01U USB microphone and cannot get satisfactory input levels from it no matter what I do.

I’m wondering if any other Ardour users have had similar problems with it.

I realize that it is a ‘stereo’ mic of sorts with one channel producing louder outputs, but in my humble (uneducated) opinion, there seems to be something seriusly wrong with this mic.

Any suggestions to get higher input levels?

With the Logitech it produces satisfactory sounds speaking six inches away; with the Samson to achieve similar results, I would need to be almost ‘mouthing’ the mic.

Anyone have any success with it?

I have one of these.What are your hardware/os specs? I’ve found this mic works well under ubuntu 8.10 and up, but only on intel. In fact, this was one of the main reasons I switched my ibook back to osx, because it’s an old ppc g4 and I got the same problem you’re describing when I used it with that setup. Otherwise, I find that it works just great in OSX tiger, but I admit I haven’t tried it on Leopard or Snow Leopard.

I’m running Mandriva 2008.0 (soon to be upgraded to Madriva 2009.1) on HP xw4200 Intel 3.4Ghz with 2.5G RAM using the Intel ICH6 onboard sound.

I’m glad it works for you, but the fact that it is USB seems to preclude the use of a soundcard (if I’m correct in this assumption). Unless I can get it functioning at least to the standard of the old Logitech, I will probably have to sell it to someone who can use it.

Btw, what are the mixer settings for your Ubuntu - is the ‘Capture’ control set?

I’m really at a loss on what to do now . . .

Maybe you can try the things in this tutorial:

I did some research on this particular microphone. I found that there were
issues with the gain setup in the mic itself. A Samson engineer, who was on
the design team for the C01U, responded to a tech support question:

He said that he had used a chip that has two digitally controlled variable
gain amplifiers, stereo ADC, and USB transceiver. A key piece of information
about this chip is that it provides analog outputs after the variable gain
amplifiers, but before the ADCs. Since the chip is stereo and the mic is
mono, he played a cute trick. He cascaded both variable gain amplifiers by
taking the analog out of the first channel and feeding it to the input of the
second channel. He got more gain adjustment range this way and he says that
the performance is better too. So only the second channel should be used at
the computer. But both of those gain adjustment controls affect the sound. So
they need to be moved together in some special way to get optimal

Apparently, if you mixer-adjust the right channel to 100% and left to 60%, it produces somewhat better output. I guess it’s a case of ‘Buyer Beware’ – this was the first time I didn’t google for ‘Samson C01U problems’ – sigh . . .

I think I’ll dump the C01U and use the Logitech.

Thanks for the replies.

to get the mic to work with a soundcard, just choose the mic as the input device and the soundcard as output device in qjackctl.
Guessing from my limited programming knowledge, I’d assume that older versions of the driver cause the problem (as the code should be the same on linux ppc and linux intel). Try giving it a shot after your mandriva 2009 upgrade, you might be surprised.

Sloppy design is the main problem with the Samson C01U, despite its flowery advertising. The seller has been gracious enough to offer a full refund. I have upgraded to Mandriva 2009, and to be honest, I have little motivation to try it again. The Logitech works great and sounds good enough right out of the box. Too bad though - it was a mighty impressive looking mic.

Thanks for your help.

Hi! My name is Karen. I joined this site to spam it, but 35 minutes later my account was deleted along with the text of my message.

was a comment on the above post, but not relevant now due to the superb house keeping here


Samson CO1U USB Gain Problem. On my Mac this has been a problem that came up when I switched the same Samson USB mics between laptops, which I have just solved. I am using two of these for stereo recording, but the issue is the same for a single mic. The source of this potential issue is the fact that even though these are mono mics they have two channels, and both channels must have their gain all the way up in order to have full gain from the mic. On a Mac, go to the AudioMIDI Setup Utility in the utilities folder, select the Samson mic in the dropdown for “Properties For”. Under “Audio Input” you will see the option of 1 or 2 channels. Select 2-ch. Down below and to the left the L & R volume sliders for both channels should be all the way to the right. Make them so and you have maxed the mic’s internal gain, which can be later adjusted down in your recording app without affecting this internal setting. You can now put the mic setting back to 1 channel without affecting overall gain. If you use two mics for stereo, set each mic like this individually, go to the Aggregate Device Editor under “Audio” on the menu bar, aggregate the two mics, and you are done. If you need to balance the gain on these mics afterward, you can do so by selecting them individually, making any changes, and then go back to Aggregate Device as the Default Input and Properties For. (There may be similar configuration setting on a PC.) Hope this helps!

Thanks morphix for the tip.

I decided to return the mic rather than mess with it any further.

I purchased a very similar-looking microphone, Behringer C1U, plugged it in, and have had no problems with the output/gain levels whatsoever.

Earlier I had tried what you suggested (setting it as a stereo device/fiddling with the output/resetting as mono) and noticed only a very minute change in output levels. To be fair to Samson, the mic may have been defective, as the supplier has suggested. However, I would not purchase another Samson product because of my experience with the C01U – ‘once burned; twice shy’.