Samplv1 users (does it work for you?)

Hi ardour people!

I notice a couple of users have reported that samplv1-lv2 works for them, can they tell me what version and distro?

Here samplv1-lv2 has never worked, and I contacted the upstream author – which he informed me that if it works with Qtractor or another daw that I should then contact ardour…

So I tried samplv1-lv2 in Qtractor and it works without a hitch, …
https://tracker.ardour.org/view.php?id=7291

maybe it’s a regressive bug somewhere but I also tried the suggestion on ardour’s bugtracker thread to rewrite a specific rule line in order to get it working on Ardour.

Do a lot of people use samplv1-lv2?

Here->samplv1_jack works… and maybe I should get back to contacting upstream again, …

I am using the lastest nightly build of ardour and it’s not the first time samplv1 is an issue for me…

It’s strange how only it is “me” that could be having the problem. lol

Out of curiosity, where does your version of Ardour get installed from? Your distro or this website?

    Seablade

Arch LTS, Ardour 5.12-11, Samplv1 0.9.9-1 both from oficiall arch repos - everything works flawlessly.

What does “does not work” mean? Are you referring to the GUI or the plugin without the GUI?

hi paul, yes I am referring to samplv1-lv2 that others have reported to work well for them on this forum. In fact I have spoken to the upstream author of samplv1-lv2 and he told me that if his plugin works in Qtractor that I should then contact you guys… I ran the nightly build from this morning, and my system is a very vanilla Debian buster 10 64-bit, so I can’t see why rgaeus said it’s not going to be fixed unless it is true, samplv1-lv2 is not self-contained well enough that it would still be crashing ardour.

According to him(author of samplv1) suspects the way you guys are coding ardour is by an old fork of a font library and by that I think he has a strong argument…

This is what he wrote to me earlier today
( https://sourceforge.net/p/samplv1/tickets/15/ )
"as said on first comment reply, the issue relates to the harfbuzz library API, for which ardour has long ago taken an old version of it, possibly due on other time and place of build, and the one that Qt5Gui is requesting as of now.

there’s strong evidence or suspicions that this breakage trouble happens most probably on later ubuntu (>= 18.04 LTS) and debian (>= 10), meaning later than the former ardour5.12 package build you have.
"

Rgeaus also wrote to me that Ardour is going towards supporting only plugins that are self-contained…

^ If that still holds strongly today, then it should be resourceful to inform users of this on the documentation so that users who like myself are running “ldd” everywhere to making sure there are no missing libraries everywhere can determine whether to report that there is a problem in Ardour.

^^^ especially because here I am running the beta build, and information is important for us to know and report problems when we see them.

thanks

I’m using the nightly build directly from this site…

I spoke to the author of samplv1-lv2 and I explained to him samplv1 0.9.8 was also failing, … according to him the problem is the forking of a core font library ardour is using. I found out today that rgaeus said this is not going to get fixed due to design/goal issues for supporting self-contained plugins, so I guess there’s nothing further to worry and report about…

For future reference, the link I’ve posted on the tracker is:

http://lists.ardour.org/pipermail/ardour-users-ardour.org/2018-November/028948.html

I have to install the newest version of this plugin
samplv1-lv2 0.9.4 on AVLinux 2019/ Debian 9.8 works good

@ahms I’d go with Pauls reply.

Could you gear down and explain - in a short sentence or two - what doesn’t work? Does it not produce sound? Is it not possible to install the plugin aka Ardour doesn’t list it?
Maybe I missed the statement along the lines, but I’d gladly help out. Cheers, man.

BTW Yes, samplv1 LV2 works stable on Ubuntu 18.04. + Ardour 5

it’s already explained on the two links provided which go into more detail.

https://tracker.ardour.org/view.php?id=7291
, the other one rgareus mentions…

Ah, thanks for clarifying. And I can’t reproduce the scenario on my system.
To be exact: Ubuntu 18.04.3 LTS + Ardour5.12.0 (built using 1:5.12.0-3 and GCC version 7.3.0)

On the fly, I couldn’t figure out the Samplv1 version - at least not with with lv2info or lv2ls