Sampling Rates

I have just bought my new recording computer, I have installed Linux and am using it for the first time. I’ll have many questions since I’m so new to the OS and an unorthodox DAW (having used Sonar for so many years), but here is my first of many questions:

I can’t seem to find the place to change the sampling and bit rate. Does it default to 24 bit @ 96 khz?

Ardour gets its sampling and bit rates from JACK. Depending on your distribution, this should be somewhere in the “Applications” or “Software” or something menu and called “JACK control”, but whatever you’re using it’s accessible in GUI form by going to terminal and typing qjackctl. From there it’s pretty simple to work out.

JACK defaults to the highest bit rate and sampling rate your hardware to handle, and if you want to run a session at some other rate it’s best to change this before running Ardour.

Hope that helped!

Wow solved one problem, created a new one.

(this should probably go under Linux subforum, though)

Turns out I hadn’t installed the Jack Control package. So I did, I load it, check everything out. Then all of a sudden Jack cannot connect to the Jack Servor, and now Ardour won’t boot because it can’t connect to Jack. The debug window says refer to the message window, but unless I’m mistaken, its the same thing.

EDIT: I’ve kind of figured this out, I’m posting a new topic over in the Linux forum because I have yet another problem. Thank you.

Is jackd installed? You may have just installed the frontend (GUI) portion of it without the daemon (the actual JACK server).

What distribution are you using? Some distributions might not automatically install jackd if you install qjackctl.

JACK defaults to the highest bit rate and sampling rate your hardware to handle

No, it defaults to 48kHz (assuming your hardware can handle that) even on 96kHz and 192kHz capable hardware.

Hi there. I’m going to allow myself to renew the old thread since the problem is related.

I have OpenSUSE 13.2, jackd - 1.9.10 and Ardour 4.1.0 and the, well, problem is what follows.
When I open qjackctl first, start the jack server and then start Ardour, the new session is always at 48 kHz; if I open some previous session with samplerate 44.1 kHz in the same order I get the warning about the sampling conflict and asking, whether to open the session anyway or not. I can enter any sample rate in qjackctl setup window, i.e. 44100, but the qjackctl window displays 48 kHz anyway and so it stays in the session.
But! when I open the brand new, shiny Ardour, which since the v 4.0 doesn’t require jack (does it associate somehow?) and the DAW starts jackd automatically, I can do whatever I want with the samplerate - set it to 44100, 48000 or whatever I want and it does apply to the session, either new or the previous, existing one (here again, if the rate is wrong, I get the warning message, which is now completely understood). More: I can switch the session sample rate while having the session open, which I’m not sure should be allowed.
Everything relates to situation when using jack as the audio system and ALSA as the sound driver, obviously.
Even more: It just came to my mind to open qjackctl AFTER the jackd was started by Ardour and now I have 44.1 kHz session while qjackctl stubbornly states it’s 48k.

The so called ‘well, problem’ is partially solved, as I said, but the qjackctl window is a brilliant tool and I’d like to use it with its full potential.
Is this more of jack issue or an Ardour issue? I don’t have an opportunity to check whether changing other options in qjackctl have any impact on the jackd.
Again, it’s not a crucial thing, but I’d like to understand and solve that, maybe.

Thanks in advance.

Old thread may go along with your old system :slight_smile: Until recently (sept’14) there was a bug in jack2 that prevented temporary jack2 from terminate properly. Once started jackd won’t exit. Could it be that qjackctl never re-started jackd with the proper sample-rate but only dis/reconnected from the running jackd ? (check qjackctl’s log window). also try killall -9 jackd jackdbus then start over with qjackctl.

These days it’s also quite common that many soundcards only support 48KHz. jack2 will start up anyway and use the closest sample-rate that the device supports.

you can run jack_bufsize on the commandline which prints the actual samplerate & buffersize currently in use.

Many thanks for your suggestions. OpenSUSE is not such an oldie compared to my laptop… It’s a rocky path to get things to work using my hardware, especially on linux.
Jokes aside - the jack process terminates just fine and the log’s clear - it starts and ends where it should. After quitting qjackctl I’ve tried your jack_bufsize and got the message that there’s no process found, which is correct. I’ve tried it again while working with Ardour and whithout qjackctl, with the 44.1 kHz session, and… well, if the terminal doesn’t lie… jack uses 48k permanently. It seems you’re right about the fixed sample rate, then my sound card is just poor :wink: I’ll try it again with Presonus Audiobox USB tomorrow.
Again, but-but: Starting Ardour with no qjackctl, then setting the session properties, hitting Apply, then OK, gives me a session in 44.1k; jack_bufsize shows 48k; assuming that jack doesn’t lie, does Ardour then? But Ardour is slave, AFAIK? Or if both don’t lie, is the resampling done so swiftly on the run? I can’t get it, I can’t believe it.

Basically my concern is that mostly I get audio sampled at 44.1k and I don’t want to force Ardour to resample every track while importing it to 48k session. It takes loads of time and I have to cross my fingers not to get any crackles after that. Second - I really need to understand: Ardour says this, and jack says that and how’s that it doesn’t crash, warn the user or… I don’t know. It shouldn’t work, should it? Why does it then? :slight_smile: Do I miss something really basic?

Again, thanks, x42, take care!

JACK doesn’t lie, but Ardour also doesn’t report any mismatch between the SR obtained and the one requested. Your audio interface only supports 48kHz; no matter what you ask Ardour or JACK to use, it will run at 48kHz and since neither JACK nor ALSA resample, the session will also be running at that rate. We’ve had the debate many times over whether or not “ask for rate X, got rate Y” should be flagged as an error or not. It isn’t as simple a question as it may appear …

Thank you Paul. I’m not a programmer nor the DSP specialist, so I take your word ;]
Seems it’s time to get some proper gear and to forget about the issue.

Thanks again guys, over and out.


…to close the topic for good: another hw (Presonus Audiobox USB) works just fine, jack shows proper SR and now I’m all happy and can go catch some peaceful sleep. Thanks for the support people, take care.