Sample rate issue

I am confronted to a strange issue.
I opened a session at 48 k then record my audio and had several takes until here everything is ok .
Then I consolidated the intervals to get rid of useless audio ( and as I am always rushing, cleaned the session ) and then audio could not be heard .
So no worry, closed the session, rebooted the PC and … Ok audio is back but you know …, with the Donald Duck’s syndrome.
All the files seem to be resampled in 44,1 . So if I open the session properly : no good ,but if I force it to open in 44.1 then it sounds ok.
If someone has an idea.
By the way I have already been confronted with this when someone recorded a session ( I don’t remember the name of Ardour’s equivalent for live sessions) with it and it was in 48 k but when I tried to open the files I had to read them in 44.1…
If someone has a clue.

I don’t know windows audio well, but this could be a hardware issue. If the audio interface is opened at a rate that the device doesn’t offer or the device is synced externally, it could seem to be at 48k when it is actually running at 44k1. Now in your case the device can do 48k, but it seems while recording it is not. Ardour runs from the devices clock rate (interrupts) and so if the actual rate on the card is not what was asked for, Ardour does not know. For example, if you are using a spdif input module to your sound card or adat to sound card, it could be that the adat or spdif module is acting as master clock and is set to 44k1. Anyway, just a guess.

Well I don’t think so .
I have an internal card as master clock and external converters seem to follow it well ,
It really seems that there is a change inside the files ,
If I try to open them in an audio editor the sample rate is wrong but by changing the hardware sample rate ( what I call " force Ardour to open in 44.1") then they sound ok.

Well ,sorry,sorry !
I guess you are right . It must be hardware related !!!
I don’t know what I am doing ,but I DO a thing which makes Ardour think that audio should be coded in 44.1and read in48 ( meaning files are unusuable)
It must be related with Windows sound device assignation : meaning ,If I use the Ardour’s audio card as the default Windows device ,It makes a mess somewhere…
If I understand what I am doing wrong, I will let you know.
Edit : By the way ,the audio recorded at 48k was ok , the issue occured after I " reduced" ( consolidate) the layers,ie somewhat after some kind of edit .

The reason I picked HW is that it was on restarting that the problem showed up. So on recording Ardour asked for 48K but for some reason (again I don’t know windows) either a sync issue with the HW itself or another program was using the device at 44k1 and had it locked there, the windows audio system did not change the rate to 48k and was running at 44k1. When your session crashed and you had to restart, Ardour again asked for 48K and because whatever condition caused the false rate the first time was no longer there, the device did change to 48k and sounded wrong. So in effect the wave file that have your tracks in them were recorded at 44k1 but are labeled as 48k. It seems to me it would be a good idea for Ardour to report an error if the timing of interrupts does not line up quite close to the requested rate.

Hi Len
I guess I opened something and did not Check the master clock sample rate .
The only thing is that I don’t understand why Ardour did not see It.
I don’t remember exactly but I think that generally in this kind of situation,there is an alert saying :" the soundcard is not set at the right sample rate "

I’m having a similar issue. I recorded some music today at 44.1k on a Windows laptop using a Sound Devices USBPre2 interface. The files play back just fine on the Windows laptop. When I copied the files over to my Mac, they show up as 44.1k files (I checked using the MediaInfo app), but when I import them into either Ardour, Mixbus, or Reaper, in a 44.1k project/session they play back at slower than normal speed. I can’t figure out how to fix this. I’m using the same Sound Devices USBPre2 interface on the Mac.

You MUST ensure that the hardware is running at the correct sample rate. Ardour does not resample to adjust to different hardware sample rates. So if the session or the files are 44.1kHz but the hardware is running at 48kHz, you’ll get the effect you’re hearing.

Thanks – I think the interface is set up for 48k, which explains the problem.

FYI, in case anyone else makes this mistake, there is a solution that worked for me. There’s a free Windows utility called Header Investigator by Rail Jon Rogut that allows you to simply change the rate written into the .wav file header. No resampling required. I opened the edited files in Ardour on my Mac and everything sounds great. I imagine there are similar utilities available for Linux.

This makes no sense, unless the original files were created incorrectly. Ardour pays no attention whatsoever to what is in the header EXCEPT that it will resample them if necessary when importing (via copy).

What did you change the rate to?

I changed it to 48k. It may not make sense, but it works! Here’s the chain of events:

  1. I normally record and edit music on a Mac, which automatically adjusts the sample rate of my Sound Devices USBPre2 interface based on the sample rate of the session (I’ve tested it a few times to verify). But this time I was using a new Windows laptop to record, and apparently Windows doesn’t communicate the same way with the interface. The upshot was that I had set the sample rate in my Ardour session to 44.1k but the interface was set to 48k.

  2. The recorded files played back fine on my Windows machine, but when I imported the session to my Mac for editing they played back slowly and at a lower pitch, indicating a sample rate issue. Creating a new 48k session in Ardour and importing the files did not fix the problem.

  3. I did some online searches, and found this, which explains that my sessions were actually recorded at 48k but labeled as 44.1k.

  4. I then did some more research to see if there was a way to simply “relabel” the files to 48k and then import them into a 48k session instead. That’s when I found the link to the Header Investigator utility. I downloaded it to my Windows laptop, opened copies of the audio files, and changed their sample rate in the header from 44.1k to 48k. I then created a new 48k session in Ardour on my Mac and imported the files. They play back perfectly.