Running VST instrument in Ardour


(Paperstreet) #1

I have spent hours reading posts that are supposed to answer this, but so far, no luck.
I just installed Ubuntu and Ardour yesterday, and would like to use it to run VST instruments, such as this Wolpertinger distrho thing.
So I downloaded the archived folder and untarred (I think that’s the jargon) it, but I still cannot figure out what the heck I am supposed to do with the contents of the folder now that it is “untarred”.
The instructions in the Ardour manual mention something about a usr/lib/lv2 folder or such, but there wasn’t one. So I tried to create one in the lib location but was told I don’t have permission to do that.
Could somebody please give me step by step instructions? Thank you.


(Paul Davis) #2

Did you read: http://www.manual.ardour.org/working-with-plugins/getting-plugins/


(Paperstreet) #3

Yes, Paul. I did. It says to put the plug-ins into folders that do not exist in my lib directory, nor can I create said folders due to not having permission to do so.
Thank you, LeatusPenguin. I will try the KXStudio repositories.


(Paperstreet) #4

“LADSPA plugins are shared library files. They need to be installed in either /usr/lib/ladspa, /usr/local/lib/ladspa or in a directory mentioned in your LADSPA_PATH environment variable.”
None of those directories exist. Also, I have no idea what the LADSPA_PATH environment is, nor where to find it.

“LV2 plugins are folders/directories. They need to installed in either /usr/lib/lv2, /usr/local/lib/lv2 or a directory mentioned in your LV2_PATH environment variable.”
No such directories exist. And again, I don’t know what an LV2_PATH environment variable is, or where to find it.

“Linux VST (LXVST) plugins are distributed as shared library files. They are typically installed in /usr/lib/lxvst, /usr/local/lib/lxvst or a directory mentioned in your LXVST_PATH environment variable.”
No directories. Don’t know what LXVST_PATH environment variable is.


(Paperstreet) #5

This is my scenario:

  1. I downloaded a file called “wolpertinger_linux64_20120518.7z”
  2. I extracted it into the downloads folder, so now there is a folder called “wolpertinger_linux64” sitting inside the downloads folder.
  3. This folder contains a folder called “lv2”, a folder called “standalone”, and a folder called “vst”.
  4. The “lv2” folder contains a folder called “Wolpertinger.lv2”.
  5. Inside “Wolpertinger.lv2”, three documents can be found: “manifest.ttl”, “Wolpertinger.so”, and “Wolpertinger.ttl”.

If I understand the instructions in the Ardour manual correctly, the “Wolpertinger.lv2” folder is supposed to be copied into a folder in my usr/lib directory, by the name of “lv2”.
So. I try the following:

  1. I click on a filing cabinet icon on the upper left hand side of my screen, which opens up an explorer type of window.
  2. I click on where it says “Computer” under a list of “Devices” in the left panel of the window.
  3. I navigate to the “usr” folder.
  4. I navigate to the “lib” folder.
  5. I look for a directory called “lv2” inside this “lib” folder. It is not there. Nor are there any directories called lxvst, or ladspa, or anything of the sort.

I thought perhaps I had to create these directories myself, seeing as they do not exist. But that plan was thwarted when I received a message telling me that I do not have permission to create a folder in the lib directory.

So, my question is, where am I going wrong in following the manual’s instructions?


(Paperstreet) #6

LeatusPenguin, I went to the page you linked to, but I cannot figure out where I download the KXStudio repositories.
(A repository being a place where things are stored).
I went to the downloads page, thinking maybe the repositories would be there, but all I found were files called Cadence, Clara, and Festige for download. Are these the so-called “repositories” I seek?
Thank you.


(Paperstreet) #7

This is what I want to accomplish:
Over the past 20 years or so, I have been using PCs and Macs to run music composition software, including Logic, Cakewalk, Ableton Live, Cubase, etc. I currently run Mixcraft 6 on my Windows HP laptop.
I use it to record audio such as guitar and vocals, and I also use it to create midi tracks with virtual synths and so on.
And that is exactly what I would like to do in Ubuntu, as well.
Someone suggested that I should probably have installed a multimedia version of Ubuntu that is specifically geared for creating music and video and whatnot. However, this one is installed now, so I am trying to make the best of it.


(Paperstreet) #8

Ok. So I looked at the page you linked me to, and in the Ubuntu section, I assume I copy and paste the lines of code that into a terminal. Is that correct?
Because I have done that.
Now what happens?
I opened up the Ubuntu Software Centre - the folder with the orange shopping bag icon on the left of my screen - and tried to find KXStudio in it. I couldn’t find it.
Thank you for your patience. I’m getting older, and it’s not as easy to learn new things as it used to be.


(Paperstreet) #9

I searched the Software Centre, and I found the wolpertinger thing, so I installed it by clicking the install button.
Now… how do I access it as a virtual instrument in Ardour?
Thanks.


(Paperstreet) #10

I have Ardour open, and I go to the “Track” menu and select “Add track or bus”. There is a field called “Instrument”, with a drop down menu. The only thing in the list is “Reasonable Synth”. How do I access the plug-in I just installed?


(Paperstreet) #11

Where is the plug-in manager? I tried reading the manual, but the page titled “Plug-in Manager” is blank.


(Paperstreet) #12

Ok. Yes. I found it in there.
I had to restart Ardour.

I seem to have another issue, if you wouldn’t mind helping me out with it…
How do I use my M-Audio KeyStudio as a midi-controller?
Thank you


(Paperstreet) #13

I assume I have to keep the terminal window open the entire time I intend to run Ardour with my KeyStudio, because when I attempt to close the terminal it says that a process is using it.

Thanks very much indeed for your help. :slight_smile:
Have a great day!


(Paul Davis) #14

You can also start a2jmidid from inside qjackctl.