Running Guitarrig 2 VST (not only) on Ardour

Hello all,
I’d like to share my expreience&problems I ran into when trying to use Guitarrig 2. I’ve succeeded to run it independently on ardour by little “tweeking” on standalone FST:

  • first compile FST (latest version I found is 1.9) and install GR2 with wine
  • when trying to run ‘fst /path-to-GR2-VST/Guitarrig 2.dll’, it hangs most probably (95%-100%) (or waits for something, futex(…FUTEX_WAIT…)=0). Experienced on 2 computers, both running Kubuntu Edgy.
  • I found out that by using strace in front of the wine command in the fst script (see below) the probability that GR2 runs properly is much higher - on one PC 100%, the other one 95%. When it hangs, restarting Jack does the trick and it works again after re-entering the command.
    I suppose the hanging problem is somewhere with Jack communication, I haven’t tried the latest Jack version 0.102.20 (compiling problems) but 0.101.1. I am not sure if that helps though (wait until Feisty release and try out)
    So my suggestion how to run Guitarrig 2.0 as standalone is editing the last line of ‘fst’ so that it reads: ‘exec strace -o /dev/null “$WINELOADER” “$apppath” “$@”’
  • unfortunately, when trying GuitarRig 2 with the built-in FST in Ardour (compiled the latest source with VST=1) I ran into the same problems as in the standalone and GR2 behaves the exact same way, hanging when trying to run. This time, though, I can’t add strace in front of loading wine as I don’t know where to put it in the source before compiling Ardour…(the other thing is I don’t know how exactly Ardour deals with VST plugins as I haven’t found any script for this)
    Any suggestions how to tweak Ardour that way? Regards, kuni

This kind of behaviour is typical of the VST experience on Linux for many plugins where the authors didn’t avoid playing games with the Windows API. Wine is a good emulator of Windows, but not perfect, and it would appear that GuitarRig is going something that Wine doesn’t support correctly. You have no choice, I think, but to wait for a newer version of Wine which might improve the situation.

Sorry to be the bearer of bad news.

Hi paul,
thanks for the comment…nice you have read the thread, might I have a question for you: is there a way to let Ardour load the plugins with strace? (as described above, I mean ‘starce -o /dev/null wine…’ instead of just ‘wine …’)? That little trick seems to help Guitarrig (and possibly other plugins) to load at all…
Thank you, regards, kuni

you would have to edit the ardourvst script that actually starts ardour. not very hard to do. let me/us knows if it helps.

Hi all,
indeed, editing the ardourvst script in the fashion described above helped, here are my first notices/experiences:

  • there are still occasional hangings when trying to load Guitarrig inside Ardour that behave the same way as in the standalone (no surprise). Neverthless, they are rather rare.
  • Unfortunately, it seems that Ardour itself doesn’t deal with Guitarrig 2 properly:
    when loading Ardour (restarting Jack just before recommended), all VST plugins are loaded along with it. GR2 loads properly (99%) and Ardour starts.
    first bug: in the VST plugin menu there are #inputs = #outputs = 2, so that I can assign GR2 just to a stereo track. Ardour apparently detects #I/O incorrectly.
    second bug: after assigning GR2 to a stereo track (by choosing ‘add’ then ‘connect’) and trying to Edit the plugin, TWO windows appear instead of just one: the first one belongs to Wine (the wine icon in the corner) which actually displays the correct GR2 window. The other one is just a blank window (belongs to ardour) and with ‘ardour: Audio 3: Guitar Rig2’ written on the bar. The problem is - when once closing the correct (Wine) GR2 window, I won’t be able to re-open it anymore. Next time just the blank window appears! I guess an ardour bug with not handling with windows properly. I might post some console log if asked for.
    Right now, there’s a way to use GR2 - when having all guitars stereo and, not closing GR2 windows, just minimize them.
    Though it’s not ideal, at least it works…

Run winecfg, go to the “Graphics” tab and un-check the “Allow window manager to manage created windows”. This way the VST gui will appear inside the ardour plugin window.

What do you mean by “Ardour detects I/O incorrectly”. What do you believe the I/O configuration of GuitarRig to be?

Regarding the plugin GUI editor, it would appear that you haven’t read We probably need to put a link to it in a more obvious location.

Finally, I would not waste my time trying to run a VST plugin that requires a massive timing slowdown in order to avoid deadlocks. There are many VST plugins that work without any hacks at all. Whether the error is in Wine or GR is really hard to say, but for me personally, it would just out of the question to run it the way you are doing.

First, my apologize for not reading that page to the end. After the check in winecfg GR2 runs fine unless clearing the plugin from a track and re-inserting it again, then just a blank window appears.
OK, my expression about I/O was a bit unhappy, GR2 is in fact a plugin with 2 I/O. The only sad thing is that I cannot assign GR2 to a mono track (a standard guitar track), when ardour expects a 2-in track.
Finally, this thread should serve from beginning as a ‘tweak guide’ or info for people who really want to run (and paid for) GR2 inside ardour as this is by far the best sounding guitar VST ever created. I can imagine a lot of people finding their way towards ardour when knowing their favourite VST runs. thank you, best regards kuni

There is a plugin called “mono to stereo splitter” which should help you put the plugin on a mono track.