Rncbc v1 plugins don't work in ardour 6.5

i recently downloaded the official ardour 6.5 binary on ubuntu studio, and i noticed that some plugins, including the rncbc v1 plugins (i.e., synthv1, padthv1, etc.) simply return a blank bus with a fader when i try to load them

for padthv1, the log says “[ERROR]: LV2: Failed to instantiate plugin http://padthv1.sourceforge.net/lv2”; the others are similar

i tried following these instructions: http://www.rncbc.org/drupal/node/1918#ardour but i found that the “padthv1_lv2:ui” was already deleted

does anyone have any advice?

if this helps anyone, i opened ardour in the terminal and tried to open padthv1, and it said this:

lilv_lib_open(): error: Failed to open library /usr/local/lib/lv2/padthv1.lv2/padthv1.so 
(/lib/x86_64-linux-gnu/libQt5Gui.so.5: undefined symbol: hb_font_funcs_set_nominal_glyph_func)

I haven’t been able to get any of the v1 plugins to work in over a year. I tossed in the towel with them a while ago … the dude that builds them is a super nice, pretty responsive guy but I found they just aren’t my bag for plugins.

At first glance, and I could be wrong, but it appears the plugins are dynamically linked, and there may be a mismatch between what it expects for Qt on your system, and what is there. That being said I believe most plugins should be statically linked, which is counter to most things on Linux, and as a result of the two conflicting philosophies you can have issues.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.