Restarting sound system after closing Ardour


I am a pretty new user of Ardour. I still have to learn all the ropes, but very much looking forward to all that. Not only that, but I have got a bit of a first user question, I guess.

I am running Kubuntu 23.04 with Pipewire. When I launch Ardour my sound system mostly gets taken over by Ardour, which is OK, because I work dedicated with the tool. After I close, however, I can’t seem to get back to the original state of my connections. I tried a Pipewire restart, but that did not help. The only thing I found restores the sound system is a reboot.

What would you usually do there? I’d rather not reboot.

Thanks and sorry I don’t have any tech details. ~ben.

So you are using the ALSA backend? That is usually recommended for new users, and should handle the hand-off from Pipewire to Ardour and back without you needing to take any action.

Do you have multiple available audio interfaces in your system? For example an interface built into the motherboard, and a USB interface? If so perhaps Pipewire switched to using the other interface once the interface you used with Ardour became unavailable.

Do you use the sound control settings application? I have two interfaces attached to my computer currently, and with that application I can switch Pipewire output back and forth between those interfaces, which is why I asked whether you have two interfaces. With the version of Pipewire I have it will always return to the previously configured interface after stopping Ardour, but I always have a very recent version of Pipewire. Perhaps your version of Pipewire or the default configuration does not return the output to a previously used interface if it becomes unavailable and you have to manual set it back.

1 Like

Thanks for the elaborate answer. That is super helpful. I am digging into that! Enough to check out here. I will let you know where I get. Thanks again :+1:

I’m on Kubuntu 23.04 as well and I haven’t noticed such behaviour. This version is using Pipewire as default audio engine for the first time. Is your system a new install or an upgrade?

However if I close Ardour, my keyboard (and sometimes mouse) stop working for about a minute.
The “ibus” daemon hangs every time I close Ardour and it takes some time for the system to restart it.

Try to install “pipewire-jack” package which is not installed by default and switch to JACK audio system in Ardour. You can use “qpwgraph” app to monitor and manage audio connections in Pipewire (something like the “Graph” window from qjackctl).

1 Like


Thanks for your reply. My Kubuntu is an upgrade. I think I have not done a fresh install like forever, and installed pipewire at some point, before it was an official part of Kubuntu. :wink: I sometimes wonder if things might be conflicting with ‘left-over’ config/apps. I am super happy, however, with Easy Effects and Helvum.

You mention qpwgraph, which I think would be similar to Helvum, right?

Sorry for my ignorance on the topic. How would I identify if I use the ALSA backend? I don’t think I do.

What is the sound control settings application? I do have two audio-interfaces, but have not used them with Ardour yet. I started experimenting a bit with audio files on my system.

Yes. :slight_smile: I didn’t know Helvum.

I am on Kubuntu 22.04 and use the following two scripts:

  1. Stop pipewire completely before doing audio work (or it will still run, taking away tons of resources and also causing havoc with some multichannel interfaces):

# stop pipewire

systemctl stop --user pipewire
systemctl stop --user pipewire-pulse.socket
systemctl --user stop pipewire.socket
  1. And another to restart pipewire. It took me ages to figure out how to do a restart - don’t leave out any of the lines, or as you mentioned, you end up rebooting out of frustration.

# start pipewire

systemctl --user start pipewire.socket
systemctl start --user pipewire
systemctl start --user pipewire-pulse.socket
systemctl --user restart wireplumber pipewire pipewire-pulse
1 Like

Excellent. I tried this, but was unable to start easy effects after that. The scripts are literal that way or does --user need to be replaced by the actual user?

I’ve never had to restart Pipewire in my Kubuntu, and I’ve been using it for a year and a half. :thinking:

You would select ALSA as the audio system in the audio/MIDI setup window:


If you never saw that window when starting Ardour then it should mean that a JACK server was detected and so Ardour used the JACK backend by default. If that is the case and you want to try the ALSA backend you can find the Audio/MIDI setup under the Window menu, stop the currently running audio engine and select different settings.

On my Fedora installation with KDE it is found with the system settings application:

Ardour will not run without an audio interface unless you specifically choose the “dummy” audio backend. You either must select an audio interface to use when Ardour starts, or Ardour implicitly assumes you have chosen an interface if a JACK server is detected, and Ardour will connect to the JACK server without asking for confirmation.
That seems likely to be the situation you are using, Pipewire exposes a JACK API, so Ardour connects to that without asking for confirmation of which interface to use.

1 Like

This is super appreciated. Thanks for taking the time! Of course, I use the sound system settings. :wink: I also have a Scarlett Solo. I am really looking forward to all this.

The scripts are literal.

Although sometimes I find I have to run the restart script twice.

My use case is Ardour for recording with a multi-channel interface runnning on bare-metal ALSA, and then running video call software and being able to share sound using the internal sound. I have no idea about “easy effects”, sorry :frowning: So at this point…good luck!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.