...reset a MIDI file to its original tempo?

I have recorded MIDI in Ardour 8.2. The performance was completely free with plenty of rubato, totally ignoring the grid. I started playing with moving the grid around to match the performance.

Is there any way to reset the MIDI region so the timing is as it was originally and isn’t conforming in any way to the grid?

Removing the markers doesn’t help as the region just conforms to the underlying tempo and time signature, which bears no resemblance to the original performance. Undo wouldn’t got back far enough and the session has been closed and re-opened since. Am I out of luck?

I’m guessing that playing with the grid is best left for audio? Or, if you are going to do it with MIDI, keep a back-up copy of the session or once you start you need to go all the way? :laughing:

Yes, sorry, there is no way to do this at present.

The MIDI file you recorded has all timestamps recorded in music time, and so it will necessarily shift around based on the tempo map.

However, that file should not have been altered in any way at this point. Ardour defaults to 120bpm 4/4 time, so if you just reset to that, you ought to get back your original performance (i.e no tempo markers at all other than the first one).

Oh, and thanks for confirming at least one use case for “fixed-time invariant MIDI while adjusting the grid”. We do plan to do this at some point.

Thanks for your response, Paul.

Okay, I’ll be careful in future when playing with the grid. Yes, MIDI shifting with the grid is very useful when that’s what you want (a feature I’ve used), but not so useful when you don’t :grinning:

That was part of the problem, that the MIDI started conforming to the grid I was trying to conform to the MIDI. And things seemed to get out of sync with another MIDI track, so I decided to back-track.

I tried putting markers for 120 bpm 4/4 just before the affected region and that didn’t seem to work as playback was too quick; removing all markers and setting the initial ones to 120 4/4 really messed things up. Probably not helped by me doing stuff in 17/8 when the MIDI was recorded :person_facepalming: It’s only a scratch session so no big deal.