Reproducible xruns on otherwise reliable setup

Hey everyone,

I’ve been using Ardour and JACK for about a year now and although there are always a few kinks, I can get the job done and get some good results out of it.
Recently, though, I’m having trouble with xruns. I recorded a strings track with my keyboard and until a few days ago I could play it perfectly fine, even with 264 settings. Now, however, there’s a certain point in the track where I’ll always get about 30 xruns within a second of playtime, always at exactly the same spot. I raised buffer sizes to 41024 (which probably doesn’t make sense, because at the critical point there’s only a single track playing with just an EQ plugin), but the problem’s still there.

I’m really puzzled! I went through loads of trouble upgrading my JACK server to JACK2 (jackdmp), Ardour 2.7.1 to 2.8.2, tried another soundcard… Where is the problem and what can I do about it?

Thanks for helping me out!

You have a problem with denormals. Google for more information on this pernicious feature of Intel processors. See the Ardour Options menu to find 3 different ways to tackle the problem. One or more of them will work for you.

Wow, thank you, finally got it back to normal (no pun intended)! This completely explains all of the weird behaviour I saw during the last couple of days, and for the most part I’m just glad to know what’s going on.
Happy End!

Okay, looks like I at least localized the problem. It’s actually not the track that’s playing but a track that’s not playing. There are three other tracks not playing at the time the xruns happen, one of them an E-Piano. If I mute that track everything’s fine, but even if I solo the quiet track I get the same amount of xruns with nothing playing at all.
CPU usage is constant at about 9% all the time, but rises to 40% or 50% shortly before the first xrun.

… I just tried deactivating some of the E-Piano’s plugins. I got two pre-fader (LADSPA “FreeVerb Version 3” and “Multiband EQ”) and one post-fader (SC1) one. Deactivating just one of the pre-fader plugins solves the mess, no matter which I choose.
This seems more and more random to me, how can a track affect anything when there’s no audio in- and output?

It seems unlikely your problem is caused by JACK since it seems to always happen in the same place on a particular track, what happens to your CPU usage at the point the xruns occur? High CPU usage will likely cause xrun problems whatever your JACK settings. Have you tried it without the EQ plugin? Which EQ are you using?