...Remove a loop section and functionality?

I know this is strange question somewhat, but either I don´t have a clue about the loop feature or I might have found a bug?

Anyways, when I want to practice a certain part before recording, I usually set up a range (press R key and then select the range I want to loop), then go to transform menu > loop > loop from edit region (that may not be accurate, as I am not in front of my machine now).

In short, it does loop the section I selected, but when I want to stop that and go back to standard playing, I can´t. Even if I remove the loop marks and click on play, it will go into loop automatically. If I move the playhead to after the loop section was, the playhead moves normally, but the section being played is the looped one?

So how should I remove a loop section? Is this strange behavior expected?


There was such a bug during some redesign of the underlying transport control, but I don’t remember this bug went into an actual release. But I think this again shows the significance that you should always tell wich verion of Ardour you are using (maybe including from what revision it was built and if it’s a distribution package or selfbuilt).

I don’t remember exactly, but maybe a workaround for this problem was to ucheck Options->Misc Options->Seamless Looping.


Thanks for replying!

I am using Ardour 2.8.2 on top of Ubuntu Studio 9.04, hope that helps!