Reinstall of Ardour Microphone Is Not Worrking

TLDR; Got hacked, malware on desktop, wiped desktop, reloaded programs, and now neither one of my DAW (Ardour or FL Studio) are picking up my microphone. I checked the Device Manager for drivers/updates/enabling, I selected the correct input device, I tried both 41K and 48K hz, unplugged replugged the XLR cable into the rear audio jack, restarted desktop, looked for windows updates, reinstalled Ardour, Fl Studio, and even ASIO4All etc. Its only my Shure SM58 I did a podcast today and that microphone was good. In microsoft record app I can select the Shure, and it picks up sound of recording. When I’m in either its not working, and I have been following the rabbit hole of help advice non of which seems to have worked.

I haven’t had any instances of malware since Windows XP, but back then, I formatted the hard drive and completely reinstalled the OS to be sure no remnants of the malware remained. If I were to come across malware today, I’d do the same thing. It was harder in those days to get an official copy of the installation media, but MS now provides the official ISOs on their website for Windows 10 and 11. Whenever I buy a Windows machine, formatting the drive and re-installing the OS using the official MS ISO is the first thing I do. It gets rid of all the cruft the OEMs put on there and runs smoother in my opinion. If all else fails, you may want to consider it.

…at the same time, your issue doesn’t sound like it is likely due to remnants of malware. It could be a lot of things, but it is most likely some settings issue between the soundcard/audio interface, ASIO4ALL, and the DAWs. There are a lot of variables, and more specifics are likely needed to help you troubleshoot it. Given it is happening in both DAWs and not in a basic Windows app, I would start by looking at the settings in ASIO4ALL.

1 Like

…and furthermore I would encourage you to uninstall ASIO4ALL, entirely.

If you are using ASIO4ALL to access your built-in soundcard, Ardour can access your built-in soundcard directly via MME. I believe Reaper can do the same.

In addition to adding setup complexity, ASIO4ALL causes some delay in startup because we open all the MME devices to check their capabilities, and then we ask ASIO4ALL to list available devices, and we re-open all the same devices again.


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.