Regular Pop/Click on vst instruments output


I’m using a Line 6 Helix as the audio interface. The Helix works correctly on windows. I’d been hoping to be able to the setup working on Linux so I don’t need to use windows anymore.

When using a virtual instrument in Ardour playing a sustained note, for example on the simple synth, there is a regular click/pop in the audio output which happens about every 5 seconds. I’ve tried exporting to an audio file and the clicking appears in the exported audio. The Audio works OK and I don’t have any clicks in the output when playing an audio file both within Ardour or within a media player application. I don’t get any other clicking in from the virtual instruments. The clicks don’t seem to relate to X-Runs, the number of X-Runs listed in is very low.

I’ve just started using Ardour on Ubuntu, I have the low latency kernel installed and the Real-Time permissions set for Jack. I’ve set the buffer to 4096 to try and get rid of the click/pop in the audio output, jack period to 3, which I’ve read as being the recommended value for a USB device and the CPU governor set to ‘Performance’.

I’ve tried a number of different configurations which I’ve found mentioned when googling these issues such as disabling the graphics card Intel audio interfaces (using blacklisting in ALSA), setting the power saving on the the Intel audio interfaces to off. I’ve also tried using different linux distro ubuntu studio, kubuntu, mint and the issues is still there. I’ve also tried installing the latest kernel available including the most current RC version, different graphics card drivers X.Org/Nvidia.

I was wondering if anyone has experienced this and found a solution.



This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.