region bounds and fades not working

i am using ardour 2.2 and i am finding that the automatic fades that are applide to clips as they are sliced are not functioning as they should.
i have tried everything i can think of to get them to work but it seems that even though its activated in the options menu and i can see the little fades on the clips, my clips are coming out clippy!

could someone tell me i am the only one, or is there a solution.


gentoo user.


i think you should start with a much more precise explanation of the problem. try to imagine that you are providing a “recipe” to someone who wants to reproduce the problem you are reporting.

ok, sorry.
what i have been working on is a simple little ditty where i am chopping up samples for replay in a sampler. i have one continuous sound like a vocal line or a brass section.

when i slice the clip up, i can see that ardour creates little fades at the bounds of each clip which is great, however they are visable but not audible effect seems to result, ie. i get clipping.

when i export one of these clips, i take a closer look using Rezound and i can see that no fade has been applied to the clips at all.

does this happen for anyone else?


yes, this behavior is known in ardour, please have a look here:

if you want your fades to be exported as well, you can do following workaround:

-go ->menu -> options -> link region/track selection (toggle on)
-now mark the track where your region is placed (the track becomes blue, but only that one track!)
-right click on region, choose 'the-name-of-the-region ->set range selection
-now you go ->menu ->session ->export ->export selection to audiofile…and do your export.

see if that works for you?


I think we are talking about 2 different things here.

NoWhiskey is explaining how to “export” a region and have the gain applied. Useful info but I don’t think it solves the original poster’s question.

gateswideopen, have you tried right-clicking inside the fade area and make sure the fade is actually “activated”? If you see a fade line but no shading, it probably means the fade is not activated.

When you slice audio, there has been a lot of discussion about how the fades should be applied. One could argue that if you slice some audio but don’t move it, there should be no fades so that you can play across the split without hearing a short dropout due to the fades. However this does not handle all the more common use cases. Maybe the version you are using has de-activated fades by default. There may be refinements to the way this works in future versions.

For now, just make sure the crossfades are “activated”. I have tested the fades and they are definitely working on my version (2.2, svn 2918). An easy way to test is to apply a fade to a region and then route that track to another track and record the playback. If you still can’t get it to work then you’ve got a bug that has been fixed in a later version.