Recordings shorter than they are supposed to be

I have just recently made a very long recording with Ardour 4.7 (~9hours of 2x mono tracks @48kHz)
Unfortunately, only 2:23h show up as waveforms in the recording (within the session), the rest seems to be empty, but Ardour plays back (other) audio, when I try and play from a timecode somewhere in that region.
The files show up to be 5.9GB, so there’s at least a little hope that something got recorded…
When reimporting those files into a new session, they are only imported as 2:23h tracks though.
I wonder what went wrong there… it’s more than 6hours of awesome session music that was lost this way. Ardour showed up having no problem during recording… so I really don’t get it.

It’s sad, but this is the 2nd time this has happened and I’m a little pissed as this MUST NOT happen EVER.
Guess I’ll buy a hardware recorder again… this way I can at least be sure my session will be recorded at all.

If anyone with a little experience in fixing (probably) broken WAVs has some suggestions, let me know!

9 hours! What in the world did you expect?

The WAV format is limited to files that are less than 4 GB, because of its use of a 32-bit unsigned integer to record the file size header (some programs limit the file size to 2 GB).[note 1] Although this is equivalent to about 6.8 hours of CD-quality audio (44.1 kHz, 16-bit stereo), it is sometimes necessary to exceed this limit, especially when greater sampling rates, bit resolutions or channel count are required. The W64 format was therefore created for use in Sound Forge. Its 64-bit header allows for much longer recording times. The RF64 format specified by the European Broadcasting Union has also been created to solve this problem.

Where do you sit regarding this? I think simply stopping and restarting the transport gives you new .wav files though.

Don’t stop playing.

@dth, well I expected too much from Ardour in this regard I guess. Thought there would be seamless jump to a new file in this case.
Will make sure to integrate W64 for this in all sessions. It’s not rare, that I end up doing very long sessions!

btw: I solved the issue by importing the wav files as raw data into audacity and exporting them again as flac. After a new import they show up in full length.

Yea you can set WAV64 as the recording format in Ardour for sessions like this for the record. I believe Waves Tracks Live defaults to WAV64 in fact for this reason, been using it to track shows recently, usually between 3 and 4 hours of recordings at 24/48 and it has worked well for it.


RF64 is also a viable option for recordings that will exceed the 32 bit file size imposed by WAV.

RF64 (WAV compatible) is an option in Ardour that will record RF64 files if the length exceeds the WAV limit, but otherwise leaves the files as normal WAV files.

CAF is another audio file format (from Apple) that also has a 64 bit size limit. Ardour supports it fully.

On the upside there’s sndfile-salvage (comes with sndfile-programs) which can convert the overlong .wav into a .w64 and save the day.