recordings disappear?

On latest release build of ardour3 from source, x86_64, debian stable.
First time experiencing this:
I have been working on a rather large (content wise but only five minute) multitrack remix for a couple weeks. It has been pretty stable while doing the edits and recordings, but twice now i noticed my overdubs have gone missing, like completely, from the session directory upon reopening the session on a different day; just ‘poof’, gone, disappeared form existence even though it exported correctly and saved cleanly with the audio files intact the night before. Majority of the takes are still there, but this seems like a random bug.
Anyone else ever experience this behavior or know why this is happening?!? I worry that this will continue to happen, and all work will be lost, having to rerecord good or unique takes.
thanks in advance for any help or input.

it is based on ICE but Envy24Control do not show the entries… or I missed something in a parameter.
In monitor inputs, I see only SPDIF
Thank’s Seablade

It seems this bathroom sound is only on return and not on recording.
Since the origin, I have no mixer on Linux for my soundcard Esp1010.
So finally, I bought an autonomous system to record… a zoom R24
It has the advantage to be used as a mixer table with effects and a good recording station.

The ESP1010 isn’t ICE based is it? If it is the Envy24Control would work for it most likely.


Which bug fix are you referring to?

Sorry, I’m not into Ardour development. But it seems you have touched the code the produces the file-loss. Before the latest release, I never have had any file-losses. And that release, which should fix file-losses, produces file-losses. Somehow weird… :slight_smile:


The issue is that there are literally hundreds of code changes in between 3.4 and this. And without a reproducible recipe so that we can test and find out which code change caused this issue, and which fixed other issues, we can’t find the exact code change that caused this issue, so doing what you suggest would mean reverting every bug fix since that version, effectively rolling back to that version.


What about an automated test, which tests every version for the MIDI-unlink-bug?

So, the code-change that caused at least this bug is identifyable. Maybe it is somehow related to the disappearing audio-files.


Again automated test requires recipe. What you are describing is effectively basic debugging techniques, and trust me they are being done if possible. For instance as we speak (type) on IRC there is debugging happening on the only recipe that has been presented that is duplicate, likely the MIDI unlink bug you mentioned. The hope is that while it is unlikely this is directly related to the missing audio bug, that it may suggest where it is, but even that is only a hope.


thank you for the insight and confirmation. if it may help at all with the recipe, i remember choosing once or twice to ‘remove last capture’ sometime before it started. also noticed afterwards that newly captured audio stereo file names became mismatched/unaligned with the correct region names, ie: Audio 4-23%L ‘ranged’ with Audio 4-24%R …and so on.

It’s really interesting.
I upgraded recently because I had noise problem when stop and start playing (when starting playing) with filter like limiters, mda multiband, autotune…
It is fine since this upgrade 3.5.357 but I do not record inside ardour.
I tried to record a track some days ago and I had a sound like inside a bathroom so… I won’t record with ardour yet.

goog luck NOYX


Ardour should not be changing the sound at all unless you tell it to. If you are having this problem without any plugins involved, something is very wrong with your system setup most likely.



I think the best idea is to get on #ardour IRC and discuss this with the devs directly, obviously you have a lot at stake and don’t want to lose (more) valuable audio data, there are a few similar reports circulating so whether this is indeed a bug in Ardour or something filesystem related the sooner the developers hear about it the better.

I recently have gone back to Ardour 3.4 on my main recording computer because I have noticed a few peculiarities in Ardour 3.5.XX with MIDI notes disappearing (or at least not appearing on the canvas properly) and although 3.4 is not perfect either you have to take into consideration that 3.5 has seen a lot of new code with both the new audio engine, improvements to automation and a lot of other bits and pieces and in my experience the shortcomings in 3.4 at least don’t put data at risk. I would also strongly suggest backing up your session to different partition or external drive until it is completely finished for the time being. Perhaps with your data backed up trying Ardour 3.4 might be worthwhile just to get this session completed while this important issue is worked through.

hello GMaq,
thank you for the good tips and other notes. i will certainly try to get on IRC soon or later. in the meantime, backups to an external before exiting the session will be quite necessary. for now i am going to use the prepackaged A3-3.5.357 to see if it happens again, but may as well have to go back to using 3.4 like you said.
thanks for your response!

We DO know about this behaviour, but so far nobody has been able to find a reproduceable “recipe” for it. Without such a recipe, it is very hard (i.e. more or less impossible) to debug.

What about reverting the bug-fix which should prevent file-loss? Things start to go wrong after that one.

Just thought I would chime in and say that, sadly, for the first time today I have been hit by the “goodbye audio track” bug. Went to load a session today and 2 of my tracks are gone into the great audio graveyard in the sky.

Ardour Version is 3.5.357 running on Tango Studio 2.1 64bit.

I cant see any reason for it. I did the same thing to three project on the same day and only 1 project is affected. I recorded drums, guitar, bass on one day (for all 3 projects) then recoded synth parts for all 3 on the next day. Only one project has lost 2 of the synth parts. I’ve tried running gdb but as it doesnt actually crash ardour I dont know what use it really is. If there is any info I can provide then please let me know (I havent yet filed a bug report as I dont see what useful info I have - if I should do so then let me know).



I believe Paul posted in a different thread that at least part of this, if not all of it, is fixed in git, it would be worth testing that if you are able to compile it yourself to see if it replicates at all. I believe the only thing holding up a release at this point may be sufficient testing as so few (Comparatively) people were affected by this and at random times it may take a LOT of testing to know for certain if it worked.


@seablade - Thanks for the heads up. Not sure how I would go about testing it. Its only affected me this one time (so far) so I have no idea how to reproduce it (and that is the whole reason testing of the patch is so difficult I guess). I suppose just create a session and add tracks, record, save, close, open - repeat.

Is it possible to build the git version without removing my current version? I am a massive tard when it comes to compiling but if it would help the devs I would be wiling to give it a shot if I can keep my current version.


Yes you can compile from git and not touch your current version. You dont even need to install the built ardour you can run it from the source.

building from source isnt the easiest, but aslong as you have the nessesary dependancies it works.