Recording Multitrack

We have the following problem: When I print the second track, the voice, for example, the first track is the drums, the second track I also voice AND drums!!!??
I want to record the voice in track 2, but to hear the drums as a guide only, so that each track has to be independent.
Thanks in advance. GVS.

You have a problem with your soundcard’s hardware mixer setting. It is recording both what is played and what arrives at the chosen capture source (e.g. line in, mic in). Neither Ardour nor JACK have anything to do with the settings of the hardware mixer (they assume that you’ve set it up to reflect what you need and want). You need to use an application that allows you to control this. Examples are alsamixer, gamix, kmix and others. Alternatively you could spend more money on a soundcard/audio interface actually designed for recording music, which wouldn’t let you do this sort of thing “by accident”.

I have a pro sound card, EMU 0404, it is true, PCI, not USB, I use Ardour on Mandriva Linux, in both beginner, after many years of Windows.
Very important is that other instruments are able to do independent , voice only not !?
What do you advise?
Thanks in advance. GVS.

@gvs: I have an emu 0404 PCI card too and I had exactly this problem, and although I can confirm that on my system it was exactly as Paul says, e.g. a problem with the setup of the audio routing in the cards mixer not anything to do with jack or ardour, it is not the easiest card to figure using the alsamixer to configure it (not because its a bad card, its actually reasonably capable, but because the alsamixer labels for the controls have almost no relationship to what they actually do) . I’m not at my audio machine at the moment so I don’t have access to the information required to tell you how to configure it but it can be fixed, so I’ll post the info as soon as I have it (unless anyone else can advise in the meantime)

So, to be clear on the issue ,I have a new and powerful 64-bit PC,with Mandriva Linux also i use Ardour to it using just Audio On Board.
I want to buy a sound card, USB probably,that has not have problems with Alsa Mixer ,Ardour, Linux, etc…
From your experience please, I saw that there are plenty of experienced Ardour/Linux users.
Maybe there is a list of compatible sound cards perfectly with Ardour/Linux.
Anticipat.thanksGVS .

@gvs: here is a list of my alsamixer settings for the emu0404 (arrived at mainly experimentally) which allows recording through the 0404 inputs into ardour and playback through the 0404 outputs. When / If I use this card it is normally in conjunction with an external mixer for monitoring (by far the best method for any setup in my opinion) so the 0404 is simply providing a pair of ADCs to get audio into the PC and a pair of DACs to get audio out. The settings are listed as Playback (outputs) and Capture (inputs). Use the TAB key to switch between Playback and Capture in alsamixer and the arrow keys to select and modify values - make sure you take note of your original settings before you change anything.

Playback (Outputs)

Master         0.0dB
Tone           Muted (MM)
Bass           50 50 (Does Nothing)
Treble         50 50 (Does Nothing)
PCM            0.0dB (Output level)
PCM Cent       Minimum (mute)
PCM Fron       Minimum (mute)
PCM LFE        Minimum (mute)
PCM Side       Minimum (mute)
PCM Surr       Minimum (mute)
Front          0.0dB
Surround       Minimum (mute)
Center         Minimum (mute)
LFE            Minimum (mute)
Side           Minimum (mute)
Synth          Minimum (mute)
Line           Minimum (mute)
CD             Minimum (mute)
Mic            Minimum (mute)
IEC958 0       Minimum (mute)
IEC958 0       Muted (MM)
Aux            Minimum (mute)
0202 DAC Left  DSP 0
0202 DAC Right DSP 1
1010 ADAT 0    DSP 0
1010 ADAT 1    DSP 1
1010 ADAT 2    DSP 2
1010 ADAT 3    DSP 3
1010 ADAT 4    DSP 4
1010 ADAT 5    DSP 5
1010 ADAT 6    DSP 6
1010 ADAT 7    DSP 7
1010 SPD Left  DSP 0
1010 SPD Right DSP 1
Analog M       Minimum (mute)
Clock In       48000 (Sample Rate)
DAC1 0202      Muted (MM)
DAC1 Aud       14dB PAD
DAC2 Aud       14dB PAD
DAC3 Aud       14dB PAD
DAC4 Aud       14dB PAD
Dock DAC1 L    DSP 0
Dock DAC1 R    DSP 1
Dock DAC2 L    DSP 2
Dock DAC2 R    DSP 3
Dock DAC3 L    DSP 4
Dock DAC3 R    DSP 5
Dock DAC4 L    DSP 6
Dock DAC4 R    DSP 7
Dock Pho L     DSP 0
Dock Pho R     DSP 1
Dock SPD L     DSP 0
Dock SPD R     DSP 1

Capture (Inputs)

Bass          50 50 (Does Nothing)
Treble        50 50 (Does Nothing)
PCM           Minimum (mute)
Synth         Minimum (mute)
DSP 0         0202 ADC Left
DSP 1         0202 ADC Right
DSP 10        Silence
DSP 11        Silence
DSP 12        Silence
DSP 13        Silence
DSP 14        Silence
DSP 15        Silence
DSP 2         Silence
DSP 3         Silence
DSP 4         Silence
DSP 5         Silence
DSP 6         Silence
DSP 7         Silence
DSP 8         Silence
DSP 9         Silence
DSP A         Silence
DSP B         Silence
DSP C         Silence
DSP D         Silence
DSP E         Silence
DSP F         Silence
Line          Minimum (mute)
CD            Minimum (mute)
Mic           Minimum (mute)
IEC958 0      Minimum (mute)
Aux           Minimum (mute)
ADC1 14d L    -----
ADC1 14d R    -----
ADC2 14d L    -----
ADC3 14d R    -----
Analog M       0.0dB
Emu            0.0dB

Thanks, but I need some clarifications ,i’m new to Linux …
I do the settings in terminal ? Write “alsamixer”; and I see all this? Or somewhere else?
Thanks .GVS.

Alsamixer is normally run from the command line. Open a terminal and type:


And you should see a display of the controls and their settings (some as bar graphs or sliders). I’ve listed my settings with the control name on the left and the value on the right. In alsa mixer you will see a row of controls with the control name under each one. Pay particular attention to the ‘DSP’ settings as this sets the internal routing of audio in the card (and I think, although I can’t be sure without spending a lot of time trying to break my system again) that this is where the problem arises with some of the audio output being routed back to the input if the configuration is not correct.

Thanks, I could, but I have a few differences from place to IEC958 0, I have S / PDIF 0.
In the Capture capitol, there you have ADC1 14d L 14d R ----- ----- ADC2 ADC1 14d R 14d ADC3 L ----- -----
To me appears, to Item ADC1 14dB PAD 0202 (in red, all 4 ADC, write CAPTURE L R )!!!???
How do I change these settings, or is normal?
Thanks in advance.GVS.

I wouldn’t pay much attention to the S / PDIF settings, these only affect the digital IO and I think the problem is related to the analogue IO. To change the settings, use the left and right arrow keys to select the control you want to change, and then the up and down arrow keys to step through the possible values for the selected control. In some cases you can use the space bar to toggle the control on and off e.g. for a mute (MM) denotes that it is muted

So I opened the terminal, I logged in as root, I wrote and appeared alsamixer Card: Pulseaudio,…
I pressed F6, Select sound card, a pop up appeared with three positions, preselected as default ,i selected: 0 E- MU 0404 PCI [MAEM8852], then F3 Playback, I set it to your model, F4 Capture, by model and … I do not sound at all …!?
I noticed that the overall volume of sound is 0 !!!???
Is a problem with Pulse Audio??
If i take the settings from the start, there are modified at Playback : Master> 0,PCM>0…!?
I can record with Jack-Ardour any signals from other sources(Hydrogen,LMMS,etc…),independently,i learn that,but not the external mixer with voice or…other.
I notice i use an external mixer Behringer,and in the same PC,with the same sound card,in Windows XP,works fine…
What can i do?

  1. You should not need to log in as root in order to make changes in alsamixer. Just open a terminal window, and type


should be all you need to do.

  1. You will see from my settings that I do not have PCM set to 0 but to 0dB. 0dB is the maximum output not the minimum. If you set PCM to its minimum value you will not get any output

Thanks,great tanks,I managed!!!

Very important.
What operating system you use to Ardour?
I have Mandriva Linux Spring 2010.1/32bit,and i have problems with sound
Need to reinstall the system to every problem!!!???
Now I sound than the Audacity to set themselves in OSS…?!
Any idea?
Thanks in advance.GVS.

On a system with AMD Sempron Mz 2400,1,75, I have Windows XP Pro SP3 and Linux Mandriva Spring 2010.1, 2010.2 now, with the same problem:
EMU 0404 PCI sound card (ie internal) is seen, I installed firmware emu … and nothing.
In “Sound Preferences” - “Hardware”, I do not see anything at Input, nothing at Outpout, "Dummy Outpout!?
What can I do, I installed, reinstalled, about 4 times, same result.
In Windows, the card works, so it is faulty or poorly installed …
Any ideas?
Thanks in advance. GVS.

Ok, I’m slightly puzzled - if I understand correctly, you had this card working in linux using mandriva - so I’m not sure why you have now decided to re-install? That said, the EMU0404 is one of those “nice” :slight_smile: cards that is essentially a dumb piece of blank programmable logic unless it is configured by the firmware (which the manufacturers helpfully embed in a windows only binary driver). The extracted firmware is available as part of the alsa drivers, however beware that (in at least one case I know of) manufacturers sometimes do ‘silent’ upgrades to the hardware, so what you then find is that if you purchase another (for example 0404) it might look the same and even have the same revision codes, but might only work with new firmware embedded in the particular windows driver that shipped with it (and therefore not with the firmware extracted by the alsa dev who wrote the linux driver). Assuming you haven’t changed the card, and you have had this card working in mandriva, I suggest that you download the latest alsa drivers and firmware and compile / install them. You could have a look at the output from lspci (although it seems like the card is recognised) and dmesg (to see if any errors were reported configuring the card at bootup). I can’t suggest much more than that without knowing exactly what you have changed from the previous (working) installation

@gvs: the first place to look to see if your h/w is actually visible is the output of the command: lspci (for PCI devices; there is lsusb for USB devices). if a device shows up there but not anywhere else, then its a driver problem. If it doesn’t show up there, its a h/w problem.

BTW: alsa has an often overlooked feature. You can use alsactl store -f foobar or something similar to write a file containing your mixer settings (maybe adding another switch to select which card to dump if you use several)… If linuxdsp still has this card in a working setup, he could store his config, send it to you and then you could restore it…

Hello! I am having a similar problem as GVS. I need the same thing, but I only want to hear the voice on my headphones as a guide for the drums. I’ve tried your suggestions above, but I’m not having any luck. Any other helpful suggestions?


I solved this issue by recording in MONO. As simple as it can be, just switch to mono in the USB IN channel. Hope it helps.

1 Like