Record On FreeBSD 7.0 With USB MIXER (USB BEHRINGER UCA200)

ok i have setup my OSS on FreeBSD system and i have output and input from various programs like xmms and audacity but i cant configure Ardour to record or even play an imported wav file and i dont know from where to start :confused:

for a weird reason ardour cannot find and device for the oss

You need to use Jack to let Ardour talk to the oss driver.
http://jackaudio.org/

I’m not sure what the situation is with running Ardour and Jack on BSD, though a google search for ‘jackd bsd’ turns up some useful looking discussion.

recently ive changed my soundcard to a M-Audio Audiophile 24/96 i have output (dunno if i have input yet i havent test it) but the problem is that i cant use the realtime with jackd! this is my output of qjackctl:

14:25:46.758 JACK is starting…
14:25:46.759 /usr/local/bin/jackd -R -doss -r44100 -p1024 -n2 -w16 -C/dev/oss/envy240/pcmin0 -P/dev/oss/envy240/pcm0
14:25:46.766 JACK was started with PID=96282.
jackd 0.109.2
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread 673190144, from thread 673190144] (1: Operation not permitted)
cannot create engine
14:25:46.777 JACK was stopped successfully.
14:25:46.778 Post-shutdown script…
14:25:46.778 killall jackd
No matching processes belonging to you were found
14:25:47.185 Post-shutdown script terminated with exit status=256.
14:25:48.788 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

anyone knows how to do this?
uname -a gives this output:

FreeBSD studio.sanityincemetery.com 7.0-RELEASE FreeBSD 7.0-RELEASE #0: Sun Feb 24 19:59:52 UTC 2008 root@logan.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386

remove the realtime option in qjackctl in the setup window and see what you get. I have no clue about realtime audio on freeBSD, never used that OS.

I’m pretty sure the ‘realtime’ problem is a permissions issue. I’m not sure where, but if I run QJACKCTL with sudo under FreeBSD 7.1 I can get realtime enabled. I know this is not ‘ideal’ but if the machine is secured otherwise, you can get realtime going that way.

FreeBSD doesn’t come with ‘sudo’ enabled. You can install it from ports (or packages) then run ‘visudo’ and un-comment out the line below with the %:

Uncomment to allow people in group wheel to run all commands

%wheel ALL=(ALL) ALL

(I know this post is old, but I just registered.)