Real time for the current user

I had to recently re-install the system due to some complications. When installing ardour I got this message again: “System does not allow realtime for the current user”
I remember that when I got it previously, I found some instructions somewhere on the net how to fix this. I created a group, ran some commands…can’t remember. Anyone has a clue where I could have seen this information?

Never mind…found it.

Hi, you should post what you did so that someone with the same problem can figure it out. And also for you in the future. Cheers

And the used distro is also very important.

On Ubuntu:
JACK server must be installed with “realtime” settings. Run
sudo apt-get install jackd qjackctl
to install it. You will be promted about realtime during itallation process.
After that, run
sudo gedit /etc/security/limits.conf
& paste
@audio - rtprio 99
@audio - memlock unlimited
@audio - nice -19

in the end of file. Next step is adding you into “audio” group.
sudo gpasswd -a username audio
It needs restart or re-login.
And dont forget to check parameters in Qjackqtl. “Realtime” must be on its place.
Sorry for English.

1 Like

To repeat for the N-teenth time, the “nice” line has no place in any RT audio setup. This is a myth that started years ago outside of the JACK community, and is not true, is misleading and unnecessary. The “rtprio” and “memlock” are the ones needed, nothing else. This is covered in the JACK FAQ.