Query about clipping

I’ve scoured the forums a bit but couldn’t really find any info directly related to an issue like this. There’s a ton of info about clipping right in ardour but it appears that my signal is somehow entering into the pc already clipped. It’s been a while since I had fired up all of my equipment so perhaps I need to play with it a bit more but here is my issue…
I’m getting distortion because of what appears to be clipping. It’s not clipped in ardour because it’s not tagged red and it’s not above 0dB but I can plainly see that the waveform hits a max level of about -3.2dB and just levels off and distorts. This happens with the levels quite low on my mixer and I can even monitor the sound coming out of the mixer with headphones and it’s clear as a bell. So it seems that the signal gets clipped somewhere leaving the mixer. I can just push the levels way down and amplify later but then my mix seems to lack a nice punch and I don’t seem to remember having to do that before. If I’m correct this is the first attempt recording on this Linux distro (Ubuntu 9.10) whereas before I was running SuSE Enterprise Desktop 10. Could it be a driver issue? My pc is a lenovo W500 laptop that runs Conexant 20561 SmartAudio HD for audio hardware. I’m going to try installing ubuntu studio 10.4 on a different hard drive in the meantime to take advantage of realtime kernel and see if it makes a difference with a different audio driver. Any tips suggestions are welcome :slight_smile:


Echo Indigo “just works” on both OSX and any Linux within the last few years. (I was using Ubuntu Studio at the time)

Make sure to specify the right soundcard when you start JACK.


Awesome! Thanks for the suggestions Ben, I’ll look into that…


Do you use your Echo Indigo with Linux or Mac? If Linux which distro??

Thanks again,

Hi Tate,

Your problem is almost certainly caused by the soundcard’s internal mixer. You’re clipping the analog input at the A/D converter, and then the soundcard’s internal mixer is reducing the digital level by 3dB before handing the audio to ALSA. When you changed distro’s, it is likely that the mixer setting was changed from your previous (working) setting.

You may be able to use your desktop sound-mixer applet and/or the command-line alsamixer application to solve this, but built-in soundcards are notoriously unclear about settings for unity gain on input and output.

Search for concepts like “unity gain” and “gain staging” to understand the fundamental issues. Then manipulate the available controls until you can feed a clean signal into your mixer and verify that you can record it unclipped at unity gain in Ardour.

Of course even with good gain-staging, your laptop’s soundcard is not well suited to high-quality recording. For simple, trouble-free recording, I’ve had excellent results with my Echo INDIGO I/O card. Or there are lots of USB and Firewire devices that will do a good job for you.