Proper jack installation on Linux

I refer to this section of the manual:

This raises multiple questions:

  1. I have jack version 0.121.3. However, I guess my jack still belongs to the first category?
  2. Why do they start at 0.124? Is 0.121.3 not supported?
  3. Neither jack, nor jackd have a "-X" argument, which is mentioned in the first paragraph. Why?
  1. jack arguments are divided into two sections:

     <code>jackd [ ARGUMENTS TO THE JACK SERVER ] -d &lt;backend-name&gt; [ ARGUMENTS FOR THE BACKEND ]</code>

The -X historically was part of the ALSA backend but in modern JACK 1 is part of the server arguments. A hack makes it work in both positions.

  1. 0.124.0 has features that Ardour requires or is greatly enhanced by.

  2. 0.121.3 is very old, and is possibly a sign that your Linux distribution doesn’t track new releases of audio software with sufficient speed and timeliness to be be considered reliable.

Thanks! I’ll try asking the admins of my Linux distribution (Gentoo) to consider jack 0.124.0 reliable.

@segmentation fault: Merry Christmas. Gentoo already has the latest jack-0.124.1. If you # emerge -av jack-audio-connection-kit in your terminal it should pull in jack 0.124.1.

@dsreyes1014: Thanks, you too. # emerge -pqv jack-audio-connection-kit does suggest to pull in media-sound/jack-audio-connection-kit-0.121.3-r1 . Newer versions are masked unstable.

Btw: Is there a list of all dependencies somewhere in the ardour repo? This would make it much easier for distributions to build their packages. For Gentoo, e.g., they have the rule “>=media-sound/jack-audio-connection-kit-0.120”, whereas paul stated that it should be >= 0.124.

Distros do not have a a problem determining our dependencies.

But please keep in mind that we don’t support distro-built packages. We use modified versions of several libraries, with patches that will never be accceptable to upstream maintainers. Without these patches, some functionality in Ardour will be compromised. This is (partly) why we make our own bundles available that will run on all versions of Linux.

@segmentation fault: Oh you’re on stable. Sorry I didn’t catch that. 0.124.1 is on unstable (which is really not unstable). I’ve been on unstable since I started using Gentoo and haven’t had any issues with updates and/or packages.