project unrecoverable

Hello again,

after copy a plugin t from a track to another ardour crashes.

The plugin is GxAmplifier, but it should not be relevant, as it was working in another track.
It crashes both ways, if I copy and paste, or when I drag it to another track.

The real problem is when I reopen ardour, it shows a message about a missing file, I select “continue” but ardour crashes and crashes.

I even tried to rename the .ardour file and open the .ardour.bak, but the problem is the same.

I even tried to remove by hand all references to that track in the .ardour file, but I should have done something wrong.

That was not a very big issue for my project, as it was a small project, and I recovered all the files to a new project, but for a big project, it could be very annoying.

I do not know if it is important, but, my versions:

Ubuntu 14.04 LTS
Ardour 4.2.546
“Taking Tiger Mountain”
(built from revision 4.2-546-gc4a3291)
Intel 64 bit

If there is anything else (some kind of log or whatever), please let me know and I will reproduce the failure.

And after the long explanation, the propposal: I think open a proyect in “safe mode” (without plugins), in “step-by-step mode” or fully could be a good idea for corrupted projects.
thank you


Actually 4.3 (And even a few revisions before that, including I am told the one you mentioned) have a command line switch -d or --disable-plugins, that will do exactly what you want in as far as loading without any plugins. Course that is primarily for troubleshooting the cause of a crash on open, if that works then one of your plugins is the cause, in which case becomes the harder processes of removing plugins one by one to find out which.


Thank you very much.

Perhaps a radiobutton or something like that when choosing a file would be better, but -d flag works fine.

This isn’t a per-session option - it fundamentally alters the way Ardour operates internally. Disabling plugins is not a trivial step (for reasons that may not be apparent to the user).

After upgrading to 4.4, it works fine.

if I insert the same plugin, now I can save it and open it later. It is a pity, the previous project keeps unrecoverable, but it does not mind.

Great work!