Program non-starting

I have just freshly installed Ardour5 to my Macbook pro running Catalina, and no matter what i do, i cant seem to open Ardour.
Installation went through no problems, but it just does not seem to want to open.
Ive tried opening from finder = applications = Ardour open, and the app icon will show in the dock bouncing, but then nothing happens from there.

I did download the trial version last night, which downloaded and installed fine, and i was able to open and have a look at the program (albiet briefly), so it seems to run ok on my system, but this fresh install just doesn’t seem to be playing friendly.
Any help would be greatly appreciated.

This is likely a permissions issue (Catalina is preventing the app from launching since it’s from an “unknown developer”). You have to right-click on the application in the finder, and choose “open” from there, and then when it tries to block you choose “open anyway” or whatever the dialog box says. But there’s another problem: you can’t record in Ardour 5 on Catalina. The problem has been fixed in Ardour 6, which is still in beta but has been quite stable for me, so if you download the current nightly build of Ardour 6 all should be well; see https://discourse.ardour.org/t/development-update-6-0-pre1-now-ready-for-testing/

I can get past that permissions box, but only to the point where it shows the ardour icon in the dock, but the actual program doesn’t load.
Hmmmmmm, you might be right, I’ll try give #6 a try otherwise I think I might be wasting my time as I’m not all that technically savvy and will be wasting people’s time by asking a billion questions but still not understanding.
Fingers crossed I can get it thou.

EDIT

Just realised that you have to have paid over $45 for the full version, which i didnt as i only wanted to see what i thought of the program before i actually gave a larger donation.
Looks like im out the money i paid (doesnt bother me though, hence why i didnt pay a large amount), but maybe would have been nice ot have known that even with a donation the program doesnt play kindly with Catalina.

This isn’t true. You have to pay over $45 to get the current AND the next version effectively. You get the full compiled version with anything over $1.

So the demo is working but the full version is not? Or did you run the demo on a different machine?

   Seablade