Program does not open up maximized

Not sure where to post this, does not necessarily matter to me at the moment but I noticed that when testing out the Ardour demo for Windows, when you open the program it does not open up perfectly full screen. I notice that it is kind of off a little bit at the edges, like off centered just a bit.
Meaning it does not open up maximized fully.
You then have to hit the maximize button or double click on the windows header and then it maximizes fullscreen.
Could just be me but has anyone every noticed this / experience this?

Like I said does not matter to me at the moment but just thought I would share something I came across.

Hope this helps

@sound8 What you’ve described is a classic desktop environment setting issue, not likely much if anything to do with Ardour itself.

It’s been years since I’ve suffered with Windows, and only a few less years since getting fed up with Apple’s money-making “ecosystem” so at this point I’m almost entirely a Linux user … but I can attest to the fact that how my various applications open (minimized, maximized, in a tray, etc.) is largely established by my window tiling choices within the desktop environment, not the applications themselves.

In short, right click on the app icon and see if you can navigate to settings within Windows as to how it opens up.

Good luck!

This might be worth trying…

  1. Choose the window you want to maximize and maximize it using the square icon (from the top 3 icons)
  2. Now press CTRL and simultaneously press the cross icon (at the RHS) to close the app.

For me (running Windows 10) the app will now open with that window maximized. Note that it isn’t full-screen (i.e. it still has the window header) but it is maximized.

I’m having the same issue in Linux.
Contrary to Windows, in Gnome, there’s no right-click option to choose maximize.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.