Problems with zynaddsubfx

Hi, i´m in trouble when try to use the synthetizer zynaddsubfx in ardour 6. The system just shut down. Does anybody knows why?

Tested on my config, no problems here. So we’ll need a lot more information, like:

  • Which OS
  • Ardour version
  • Zynaddsubfx version
  • Plugin type (VST, LV2, AU…)
  • etc…
    Any other plugins that give troubles or just this one ? Any logs you can recover ?

Hi Bart, thanks. here´s the info:

-MacOS Catalina 10.15.2
-Ardour 6
-zyn 3.0.3
-VST
-this plug-in is the only one that causes troubles.

1 Like

Sorry, it isn´t VST, it´s LV2

I guess that this is due to MacOS Catalina restrictions. zyn-fusion is special.

The plugin opens a network-port, and then starts a GUI process which communicates with the plugin over network. A likely cause is that MacOS prevents this and stops the application instead. In theory, there should be a popup question to allow this.

Then again it may also be https://sourceforge.net/p/zynaddsubfx/bugs/198/

1 Like

Thanks Robin, so, MacOS is not a good idea for this kind of software then? i´ve just downloaded an older version of zyn and worked partially, y mean, it opens the presets and let me hear the sounds, but there are no parameters to play with, and the graphic interface is missing, just can see this

i´m new in this world

There’s a standalone version of zyn-fusion, maybe that’s an option ?

i think i´ve already tried it, maybe i should look for other option, any suggestion? i need a synth

There are dozens-to-hundreds of software synth plugins for macOS. Some are commercial, some proprietary, some both, some open source, some freeware, some libre etc.

1 Like

A huevo! awesome Paul, Thank you.