Problems with MIDI-regions after tempo change

I have a problem with changing the tempo after entering a repeated MIDI-pattern:
Create a new MIDI track. Create a region and fill it with the rythmical pattern. Then Multi-Duplicate this region.
When I now change the tempo from 120 to 80, there are gaps between the single regions with the patterns and their contents are cut. The expected behaviour would be, that the whole pattern will be played unchanged, just slower. How can I change this? Or am I doing wrong something?
(Ardour 4.1.4 on Ubuntu Studio)

Yes, I have the same problem except it happens with midi whether duplicated or not - if it is a problem, that is, and not simply something I’m doing wrong.

First of all I would say update to the latest version, because it could have been fixed between 4.1 and 4.7. I run the latest 64-bit nightly and haven’t noticed anything like this, but then I don’t use MIDI stuff often.

Second, if that doesn’t help, a temporary work around, until one of the devs is able to address this, could be to just set the tempo before you start writing MIDI?

Edit: Just noticed the date on OPs post. lol

@siabost9deas if you’re having this issue on the latest version, it would be best to post a bug report on mantis, devs will notice it faster. The temporary work-around I mentioned would help though for the time being.

I tried a few times to do temp changes with MIDI, and this seems to be intended behavior. Ardour will resize the internal note data, but Ardour won’t change the length of the region. When increasing the tempo of a song with a repeated pattern similar to what you describe, I had to manually shrink each region back to its right size.