Problems with Jack + audio applications on Ubuntu Studio Gutsy


I’m quite a newbee when it comes to Linux. I’m running Ubuntu Studio for a couple of weeks now and so far I’m very impressed. Since I’m a dj for a very long time and also (very beginning amateur) producer I want to mess around with the audio applications in Ubuntu. I have been dj’ ing and producing with Reason and live…

Off course also Ardour. But when I’m trying to start it up the Jack server won’t run.

I’ve read many discussions but so far nothing helped. What I did so far:

Type in Ardour2 in the terminal, than it (sometimes) runs
Change settings in Jack (now they are as following:
Preset Name = default
Server path /usr/bin/jackd
Ticked: force 16 bit, verbose messages output)

For the rest nothing interesting I think

What I’ve done in the done in the limits.conf

tim - rtprio 99
tim - memlock 500000
tim - nice -10

this is what I’ve added after the #end of file

I tried to run jack -d alsa

And this is the output of my Jack:

16:37:47.925 Patchbay deactivated.
16:37:47.983 Statistics reset.
JACK tmpdir identified as [/dev/shm]
16:37:48.098 MIDI connection graph change.
16:37:48.216 MIDI connection change.
16:42:53.569 Startup script…
16:42:53.569 artsshell -q terminate
JACK tmpdir identified as [/dev/shm]
can’t create mcop directory
Link points to “/tmp/ksocket-tim”
16:42:54.117 Startup script terminated with exit status=256.
16:42:54.117 JACK is starting…
16:42:54.118 /usr/bin/jackd -v -dalsa -dhw:0 -r44100 -p1024 -n5 -S -i2 -o1 -O5
16:42:54.123 JACK was started with PID=5803 (0x16ab).
getting driver descriptor from /usr/lib/jack/
getting driver descriptor from /usr/lib/jack/
getting driver descriptor from /usr/lib/jack/
getting driver descriptor from /usr/lib/jack/
jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
server default' registered registered builtin port type 32 bit float mono audio registered builtin port type 8 bit raw midi clock source = system clock via clock_gettime loading driver .. apparent rate = 44100 creating alsa driver ... hw:0|hw:0|1024|5|44100|2|1|nomon|swmeter|-|16bit control device hw:0 new client: alsa_pcm, id = 1 type 1 @ 0x8059e88 fd = -1 configuring for 44100Hz, period = 1024 frames, buffer = 5 periods ALSA: final selected sample format for capture: 16bit little-endian ALSA: got smaller periods 2 than 5 for capture ALSA: cannot configure capture channel cannot load driver module alsa starting server engine shutdown freeing shared port segments stopping server thread last xrun delay: 0.000 usecs max delay reported by backend: 0.000 usecs freeing engine shared memory max usecs: 0.000, engine deleted no message buffer overruns cleaning up shared memory cleaning up files unregistering serverdefault’
16:42:54.229 JACK was stopped successfully.
16:42:54.229 Post-shutdown script…
16:42:54.229 killall jackd
jackd: no process killed
16:42:54.451 Post-shutdown script terminated with exit status=256.
16:42:56.148 Could not connect to JACK server as client. Please check the messages window for more info.
JACK tmpdir identified as [/dev/shm]

That last message is a problem I’ve seen with many users. So far any of the suggestions that were helping for other users didn’t help me.

I’m by the way on a soundblaster live value 16 bit using the emu-510 (if I’m correct) driver.

I also have the latest kernel and I’m in the group for audio. Any help is more than welcome. Thanks in advance!

I’m no expert, but a couple things come to mind…

Try starting jackd first…
Try using qjackctl program to start jackd.

If jackd does not start, make sure you do not have any other sound applications (or other applications in general) running. Try going into Preferences > Sound and turning off ESD and any system sounds also.

Once jackd is up and running try starting ardour or other audio programs that use jack. Do not start any programs that do not use jack (such as amarok or other audio players that are not configured to use jack by default).

It might be helpful to logout/login and even reboot here.

Hope this helps.

I noticed that you hadn’t checked off “realtime” in your JACK settings, since Ubuntu Studio ships with the -rt kernel you need to tick that off in your JACK settings. Also since you are using a SB Live try 1024 with 2 buffers and a sample rate of 44100, I was running the realtime Ubuntu kernel with Linux Mint and could not get my SB Live 5.1 to run at all under JACK, I installed the regular kernel and it worked fine with the settings above (minus ticking off realtime). The bad news is if you are serious about getting into production you’ll probably have to improve your soundcard.

Thank you for both your help! I’m at work now, but I’ll definately check it out toninght. I know I have to buy another soundcard (want to do that for a long time already). Including a new pc ;-). I just moved so furniture and decoration were the first priority (according to my girlfriend lol).

What type of soundcard would you recommend me for Ubuntu Studio Gutsy?

I need 2 stereo outputs and 1 input (for microphone)
and off course low latency 24 bit. It can be an internal PCI. And I want it to be supported natively in Ubuntu.

I heard m-audio delta cards are good 2 go? Or would somebody recommend me another card?

I have an m-audio audiophile 2496, which works fine. You will also want to get a mixer to get the levels right for your mic.

I see, well, Mic is not 100% necesary. I use that vor my voip things, but I want to get a sip device anyway. Or I use my onboard for microphone.

I heard that the audiophile 2496 only has one output. (I was interested in the audiophile so I read about it.)

If I want to mix I can’t preview my next song I’m afraid. But for the rest I heard it’s a good card. Maybe the delta44 would be more suitable? Than I have 4 outs (2 stereo outs…).

But any advice on a card with 2 stereo outs is welcome (1 headphone, 1 master). For the rest I don’t need more ins/outs.

But thanks for the answer!

in ubuntu studio i was type sudo scons VST=1 and after - sudo scons install and now i cannot run ardourvst as user - only as su.
and ardour tells me that it cannot connect the jack coz jack started by another user
(jack as we knows not works as su - just as the simple user)
in result - have not any abylity to use ardourvst in ubuntu studio((

Can anybody helps? may b some operation like chmod +x will help me but i donno were((

The first command is just “scons VST=1” (without sudo). After that you have to run “sudo scons install”.

When I removed my soundblaster Live and tried it with the onboard card it worked. Jack could connect to the server.

But… In one hand or the other my mp3’s in for example m-player are a couple of semitones to low. When I switch settings in my sound configuration it’s ok again, but than Jack doesn’t start up.

So there’s a setting somewhere that conflicts. I don’t know where.

Any ideas about a good sound card? I think I would like the m-audio delta 44. It has got two stereo outs. But I don’t need the two stereo ins. So maybe I could save money buying a cheaper card supported in Gutsy with just 2 outs? I don’t know… Any advice would be welcome!

of course i know it - thats y i wrote in comment about my mistake.
and now i was completely reinstall ardour as it possible with “scons -c install” and completely removed scons with synaptic and after repete installation steps with “scons VST=1” from user and “scons install” from sudo
and again cannot start ardourvst as user - only “sudo ardourvst” ((

Does anybody know (gsking1) if the audiophile 2496 gives loud enough sound if you connect the headphone directly to the analog out?

I’m now still doubting if I would really need 2 stereo outs or that 1 is sufficient (get crazy of myself :wink:

Re: Tim Hartman
its a badnews but you need some amplifier outside or really disciplined nervous system to make music through the headphones switched directly to M-Audio Audiophile (course i use the same))

and can somebody tell!!!

where is the default place for ardourvst???
coz i need change permissions to run ardourvst as user.
Now ubuntustudio tells me that no such a command “ardourvst”-
and sudo ardourvst works but (of course!)cannot connect to jack.

Thank you for the answer. Than I think it’s better to go for an external soundcard with special headphone input and volume knob. Maybe the audiophile USB makes sense.

Does anybody use it?

[edit] read some more posts on the net and also people that got the audiophile usb working very properly under Ubuntu. Picked up a second hand for a good price. Very happy. I’ll keep you posted!