Problems to use Boss FC 50 Midi Controller

Hi there,
I tried to use a Boss FC-50 MIDI Controller with the the latest ardour in Tango Studio (a Debian based audio distribution). There are two ways described to control via MIDI, capture with ctrl+ middle Mousebotton or making a map file. I tried both. First to the capturing. I did all the work to connect the devices over jack. All tests with a midi keyboard work fine, I can even capture the button of the FC-50 (it also displays a program change command in ardour’s MIDI trace window) but after the capturing nothing happens when I push the buttons again (the keyboard works).
After that I made a MIDI map like in the manual first put it in ~/config/ardour3/midi_maps folder, but it did not show up in the general midi control dialog, then I copied it in /etc/share/… to the other map files, but it didn’t show up either.
It would be nice to start and stop recording with that pedal

Kind of solved
The capturing still doesn’t work, but I found out that the map file was corrupted somehow. I copied it’s contend in a new one and … all works fine.
Maybe the capturing function on pgm messages has a bug, but for me it works with the mapfile.