Problems Installing Boost

After much trial and error, I have finally gotten all the dependencies I needed to install the newer Ardour 2.1 on my laptop. Initially, I had downloaded Ardour from Synaptic, but I found that it was an old version; .99 I think. So, I had to install Boost (libboost I think it’s officially called). I tried once, and it took AGES to “make”, and slightly less time to “make install”. While it was making, I noticed that at almost every point it paused in the terminal, something about #error LONG_LONG found but not PY_LONG_LONG, and maybe something else. I also see that I’m getting an error like this: libs/python/src/exec/cpp:48 error:
‘PyRun_File’ was not declared in this scope
, yadda yadda yadda. So what exactly does this mean? My installation of Boost is evidently not sufficiently completed to install Ardour; I already tried it again. Boost tells me that not all Boost libraries were built properly.

I’m getting the impression that maybe I need to install, or re-install Python whatever it is? As you can tell, I’m very hip with the terminology here. I will try that next, but just in case, I’m curious what other options I have, and what else might be missing…



Ok, I think I got boost to install correctly. I also got the last couple missing libraries I needed, and installed Ardour 2.1. I ran the scons command, then scons install. However, now it appears that I needed to remove Ardour .9 first before installing 2.1, because I can’t find 2.1 at all; only the old version. I went into synaptic thinking I could remove the old version there (I’m not so good with command line uninstallations, I don’t know how to do them), but it says I have to install the entire ubuntustudio-audio package to do that, which is annoying. Do I really have to do that or is there a better way? I’m of course willing to install 2.1 again; now that I have the libraries I needed it’s not so bad, but getting the 0.9 version off without having to remove the other programs is a problem. Thoughts?



Are you trying to run the program “ardour” or “ardour2” ?

If you’re double-clicking some icon and aren’t sure, then try running “ardour2” from a terminal.

Good luck,


Hah! Thanks, Michael, that worked great! Now I just have to add the launchers for that in the right places, and uninstall the old version through synaptic. I’m assuming that uninstalling via synaptic won’t uninstall the dependencies too, but we shall see…