problems getting rid of older ardour

having some problems. i am light years behind you guys as far as teminal ect so bear with me. reinstalled ardour after crash ( power surge). tried going into terminal and using the mv function to get rid of old directory as well as pauls advice from website and went to home directory. when i boot up ardourr get 2 menu bars. one for ardour, and ardour 2. can’t seem to get rid of previous version. when i shut down it is cancelled as it says ardour2 cancelled shutdown. also will not connect to jack. suggestions and thanks for being patient

Ok you are on OS X? Something is very screwy with your setup and you would probably be much better suited asking in IRC (Help>Chat in Ardour) and see if someone is around there to help you with the two menu bar thing. I have only rarely heard of that happening and I don’t think I have heard of it happening on OS X.

Where exactly did you install Ardour from? The Website? Or did you try to do it through Fink, Macports, etc.? Same question about your version of Jack by the way.


thanks seablade. downloaded ardour from ardour site. the same with jack (from the jack website )
went into terminal and ,followed steps outlined in the floss manual about using mv in terminal. there was also a link in the manual to a page from ardour where paul suggests going to the home folder and deleting the ardour2 file , which i did not find. prior to the crash it was all working well with the audiophile card. i even checked the disks in diskutility and verified and repaired any disk permissions. I may be wrong, but some or all of the original ardour package is still there. as i said the 2nd mirror of the menu bar starts with " Ardour2" and mirrors the headings in the first menu. any suggestions would be a appreciated. i even went to a website to get a list of the basic terminal commands to try and hunt doun the .ardour2 file through terminal.

Can you take a screenshot please?

The .ardour2 directory is located in your home folder, and on OS X is hidden so you can’t see it in Finder. You can however modify it with the terminal, for instance to move it to the side open a Terminal (Applications>Utilities> and type in the following…

mv ~/.ardour2 ~/ardour2-old

Then the directory will be moved to where Ardour won’t look for it and will become visible in Finder as well for the record.

As I mentioned though this is going to be PAINFULLY slow to troubleshoot over the forums, try to catch myself or someone in IRC where we can help you much faster if you can catch us while we are around.


I did do the terminal function and tried to move it as per the used a dash in the command the maunual uses a period

mv .ardour2 .ardour2.old
could this be a problem

also is there a way to delete the old folder in terminal or is it hidden as well until I move it.


i will try to join on line later

Well the only real difference is that

mv .ardour2 .ardour2.old

Will keep the folder hidden. Any file or directory on OS X that starts with a period is a hidden directory. That is why you can’t see them in Finder.

You can certainly just remove them in the terminal as well by just using

rm ~/.ardour2

It is doubtful that this will fix your problem, but I am interested to hear more about that problem, sadly I don’t think I will be in this afternoon. I will be in and out tomorrow, but if you find someone online and talk to them this afternoon Ill read it tomorrow so long as I don’t lose power, as my workstation stays on IRC and logs it for me.


i am at home now . again thanks for the help and the lessons