Problems at trying to use multiple USB interfaces

Hey guys,

I’ve recently tried to use my two audio interfaces at the same time to use four instead of two tracks for multitrack-recordings, but I didn’t find a working solution.

This was the link I was visiting:

The first thing I tried was using those ‘alsa_in’ and ‘alsa_out’ tools. While Ardour was running, they weren’t able to connect to a jack server, but in Qjackctl it worked fine. The problem is that Ardour isn’t able to start while Qjackctl is running. It seems that it wants to start another jack server…

The other thing was the pseudo-device-setting in my ~/.asoundrc file, which hardly changed anything. Where should I be able to find my new pseudo-device?

Best regards,


Using multiple audio interfaces for multi-track recording is a very bad idea, almost certainly doomed to failure, and will make your life a misery. Please don’t do it.


Unless you have 2 devices that can feed each other time clock data via SPDIF or other cable (ie 2 M-Audio 1010LT PCI cards) then as noted above you are wasting your time, even if you get an ‘.asoundrc’ that works and shows the inputs and outputs you will still have issues with the 2 devices drifting out of sync with each other.