Problem with sound on EZdrummer and others

Hello. Recently I have downloaded version 6.7 of Ardor, but I have a problem that already happened to me with version 5. My system is Linux Mint Ulyssa. The problem is that for a short time, Toontrack plugins have not worked well for me. Specifically EZDrummer, EZKeys and SuperiorDrummer, when loaded into Ardor, they do not sound. It seems that the sounds of these plugins are not being loaded. Previously if they worked well. This problem does not happen to me with EZBass, which does work normally.
No errors appear in the log, they just don’t sound. I don’t know if the problem is Ardor, or a Linux Mint update. I use a RealTime kernel (5.8.0-55), Roland Capture EX sound card. Does something similar happen to someone else? How can I solve it? Thank you very much and greetings.

Which wine are you using? Some versions of Wine Staging do not work, at least 6.3 and 6.5, so I use 6.4 and it works perfectly with Superior Drummer 2

Hi Jostein…At the moment I am using wine-hq-staging 6.10 ~ focal-1, it is the maximum version that appears to me in Synaptic. I have added the repository deb Index of /wine-builds/ubuntu focal main. How can I install version 6.4? Very thanks for your reply. Excuseme my english, is made of google translate :stuck_out_tongue:

See if you have the option to install wine-stable instead of wine-staging.
The “stable version” seems to be 6.0.1; maybe it works better.

Or try Ulyssa’s default 5.0.3 version.

I’m not entirely sure that wine is the problem since some of your plugins work, but here it is (using some terminal), lines starting with # are just comments and do not do anything (i don’t know our knowledge level, my distro is Kubuntu 20.04)):

#Open your terminal and check the avable versions if needed:
apt policy wine-staging

#Remove the current wine installation (example: winehq-staging);
sudo apt remove winehq-staging
sudo apt remove wine-staging

#install dependsis for your distro (in my case, focal = ubuntu 20.04):
sudo apt install wine-staging-i386=6.4~focal-1
sudo apt install wine-staging-amd64=6.4~focal-1

#Install wine-staging=6.4 for your distro:
sudo apt install wine-staging=6.4~focal-1
sudo apt install winehq-staging=6.4~focal-1
sudo apt install wine-staging-dev=6.4~focal-1

#Pin the packages so they’re no upgraded together with other packages
sudo apt-mark hold wine-staging=6.4~focal-1
sudo apt-mark hold winehq-staging=6.4~focal-1
sudo apt-mark hold wine-staging-dev=6.4~focal-1

#The fix in on GitHub and should be in 6.4 so remove the lock when wine 6.4 is coming
sudo apt-mark unhold wine-staging=6.4~focal-1
sudo apt-mark unhold winehq-staging=6.4~focal-1
sudo apt-mark unhold wine-staging-dev=6.4~focal-1

Hope this solves your problem, good luck!

1 Like

Hi Peder, thanks for answering. I have already tried these options, to no avail. I am already beginning to doubt that it is a wine problem, since the standalone versions work without problems, the problem only happens in Ardor, it is as if the sound libraries were not loaded, the plugin is visualized well, but it is mute.

Thanks for your extensive answer, I have followed your instructions and have managed to install wine-staging 6.4. At the moment I am doing tests but it seems that the plugins still do not work, but I want to do more tests before drawing a conclusion, I will say something in the next few hours. I really appreciate your help, my technical level is not very great.

This last part is something you should ignore (sorry, forgot to not include it). I suspect that wine is not the problem because you write that EZBass works. Do you use LinVST for making Windows plugins appear as Linux plugins in Ardour or do you run for example Superior Drummer standalone?

578 / 5000

Yes, I use linvst.4.5 for all plugins … today I have been doing some tests; I have tried to run a kernel of a lower version, in case the cause of the error was an update … it has not worked, the error persists. I have uninstalled ezdrummer and reinstalled, it has not fixed anything either. Finally I have reinstalled wine 5.0, which is the one that comes by default in mint, it has been worse, it did not even load the plugin … I can no longer think of what more tests to do, except to format the disk and install Mint from the principle … obviously I’m not going to do that: P

LAST NOTICES

sloppy solution
I have seen that if I load the plugin through ‘carla-rack’, then if it emits sound. The problem is that the performance drops a lot, especially if I load several plugins on several tracks, but at least it is a kind of ‘patch’ that can be used to use the plugin while I figure out how to solve the problem and be able to load the plugin without 'intermediaries '.
An advantage of using carla-rack is that I can also load other plugins that normally do not work with Ardor on Linux, such as some from Roland Cloud.
If I discover any more information about my problem with the loading of ezdrummer 2 in Ardor, I will let you know, thanks for your answers, greetings.

I’ve been using EZDrummer under Ulyssa though running with yabridge, not LinVST.

Usually when you load a new drum kit in EZDrummer, a progress meter shows in the kit selection box. When you say sounds do not seem to be loading, do you mean that that progress meter doesn’t do anything?

Using yabridge, there were some documented issues like this that popped up earlier in the year which have since been fixed. As @josander mentioned, there have also been some regressions in Wine and right now winehq-staging-6.4 seems to be the sweet spot. You might want to give yabridge a try, the developer is quite responsive.

Otherwise, one other idea might be to move your sounds folder. When EZDrummer can’t find it, it will allow you to set a location.

Good luck

1 Like

That’s.

I just tried it and it has no effect, when I indicate to EZdrummer the new location of the sounds, they still do not load. Seeing that when I run EZdrummer in standalone, or through carla-rack, if it loads the sounds, it seems that it is through the direct execution on Ardor that generates that problem. Also, the same thing happens to me with EZKeys and Superior Drummer …

I’m going to find information about yabridge and try, I did not know that program. Thank you very much for your suggestions, best regards, Manuel

Works! :slight_smile:
I have tested with yarbridge and it works without problems! Thanks a million, Manuel, you have been completely right … I appreciate everyone’s help again, I hope I can help you sometime. Josander: Those commands that you gave me in your answer are going to be very useful to me in the future, so I thank you for your time. Greetings to all and thank you very much!

1 Like

Excellent! Now, while I have your gratitude, could you check and see if Follow Host works? Meaning, drag some MIDI blocks to the timeline in EZDrummer and see if they play when you hit Play in Ardour. I recently completely rebuilt my computer and it no longer seems to work. Probably something I forgot to set up, but just curious. If it doesn’t work for you either, I’ll raise an issue with Robbert at yabridge. Thanks.

Well no … it seems that it doesn’t work for me either :frowning:

Besides that problem, if I drag several midi blocks, for example up to measure 30, and export as a midi file from the Track> Export Song as MIDI File menu … when I later import that file from Ardor, it only imports up to the measure number 14. It’s as if it didn’t export everything. Does it happen to you too?

And as it turns out, robbert has already fixed the Follow Host part (just yesterday). That guy is impressive. There was a regression between 3.2 and 3.3. If you grab the latest automatic build from github under the Actions link, it should work. I just tried exporting midi (for the first time) and it seemed to import into Ardour ok.

If the latest version doesn’t fix that, in his Readme he shows a bit of a workaround for drag-and-drop between the plugin and Ardour.

Best

1 Like

Hello … I have had a very thick day and I have not been able to come before, I’m sorry. Let’s see, on the one hand the issue of exporting midi: I have been doing tests in another partition that I have with linux mint, there I have installed everything that needs to be installed: wine staging 6.4, yabridge ezdrummer etc.
So I have seen that there is no problem when exporting the midi, when importing it later in Ardor it does it without errors. With which I have concluded that I must have changed something in the Ardor configuration and that is what causes the problem that only the midi file is imported in half. I do not know what is the parameter that I must adjust, I will find out in the next few days, I hope.

As for the ‘follow the host’ function, I’ll wait for the new yabridge release to be published, because the option that you tell me is the uncompiled files, and it is very difficult for me at the moment to get into these questions: P and I don’t want to go into an off-topic either.

I also tell you that I am happy with having discovered yabridge, since other plugins work for me that previously did not work for me, so I am very grateful for your contribution.

Greetings Manuel, if there is more news I will let you know.

You don’t need to compile anything yourself! As mentioned by @befloibent, you can just grab the latest build from this page by logging in to GitHub, clicking on the latest build (so one of those links with a green checkmark next to it), scrolling down the build page, and downloading the yabridge-3.3.1-XX-YYYYYYYY.tar.gz and yabridgectl-3.3.1-XX-YYYYYYYY.tar.gz archives. Extract those (twice, because GitHub Actions is stupid) and replace your original yabridge and yabridgectl files in ~/.local/share with the new ones from the archives. Then just rerun yabridgectl sync to complete the update.

1 Like

Thank you very much robbert-vdh :slight_smile: as I had not logged in, I did not get those links, I have already downloaded the new version. Beginner’s failure: Thank goodness that all of you are helping me :smiley:

Regarding the problem of exporting / importing midi, it has become a recurring problem. But I’d better open a new topic so as not to mix everything up. For my part, I consider the problem that started this topic to be solved.

…eeeh…How do I change the title of the topic to add (solved)? I can’t find the option :blush:

1 Like