Problem with plugins on busses

I’ve encountered a problem. I’m running self-built ArdourVST from the ongoing 2.0 SVN branch.

I’m creating a new stereo bus to hold a reverb plugin (TAP Reverberator). Every time I activate the plugin I get one of several things happen:

  1. Either I get white noise out of the speakers
  2. Or the level meters on two of my tracks shoot up into the red (reading +500dB!) but playback continues as normal
  3. Or one of my tracks drops out

If I add a send to a track to route audio to my bus, I can lose all audio completely. Sometimes it works.

My Distro is Mandriva 2008, and I’ve found some other general JACK-related instabilities so I wonder if this is a bug or a problem with my distro? Has anyone else tried this and had the same result?

I’ve investigated this a bit more and I think I know what’s going on. Once I’ve created my Stereo Bus and my post-fader send (on a mono track) I look at the Connections in qjackctrl. I see send1:out1 connected to Bus1:In1 send1:out2 connected to Bus1:In2 AND Bus1:Out1 connected to Bus1:In1. So it looks like Ardour is feeding the bus back into itself. Also I cannot disconnect this connection from within qjackctrl, and it doesn’t show up within Ardour.

Is this reproducible by anyone else? I still think I’m doing it wrong somehow.

Don’t know if it’s still useful to you, but did you try not activating qjackctl at all and launching jackd manually, then try to create the bus and plugin again?

Thanks, actually I think I solved this but forgot to update this post.

The solution to most of the problems seems to be to build the plugins myself instead of using the rpms. I don’t know why this is, maybe because I built my own kernel tuned for my athlon but the rpms are built for i586? I don’t know, but anyway most of the problems have gone. I haven’t had another ocurrence of the strange routing problem - I think what happened was that I had several crashes while trying to run the plugins early on and perhaps the saved project became corrupted in some way. Certainly I’ve not had it happen since. I’ll let you know if it happens again :slight_smile: