Problem With Audio Playback On Macbook

I have a Macbook and I have no problem recording tracks, but I can’t seem to figure out how to route it back to the core audio so that I can hear it. Can someone help please?


Need more info on what you’re using, but here’s some ideas you could check (probably in this order, I don’t know how experienced with Ardour you are, so I’ll start with the basics):

  1. What audio interface are you using?
    (external Firewire/USB mixer, built-in sound,etc.)
    If it is an external device, make sure you go to Apple > Preferences > Sound set the default Input and Output to the external device.

  2. Make sure you start JackPilot before you go into Ardour. Ardour will start the jack server even if you don’t, but you won’t be able to see or control things. Do a cmd-F search from the Finder if you don’t know where it is.

  3. In Ardour, each track should be assigned to an output. Open the mixer window, and at the bottom of the track push the output button. You generally want the audio tracks to go to the Master bus.

  4. Go to the Master bus Output and then to Edit. On the right, there will be 2 (or more) tabs with various output ports. Make sure the outputs it is using are not any from the Ardour tab, rather the appropriate Audio interface (I can’t remember if it says ‘CoreAudio’ or not – I’m not at my Mac right now)
    If you did your defaults in the Apple > Preferences > Sound > Input/Output tabs, this will generally default correctly on new sessions.

  5. What does it show on JackOSX? You should be able to see the Master Out connecting to the playback device for your audio interface

Hope this helps. I have some more in-depth stuff to try if you’ve already done this.

You need to configure a new “aggregated device” in mac os x. This is described in the Jack OS X documentation. It involves using the “Audio MIDI Setup” Program in /Applications/Utilities. Make an aggregated device by choosing “Open Aggregate Device Editor” in the “Audio” menu. Add an aggregated device using the built-in input and output (or whatever soundcard you use), and use this device as “interface” in jackpilot. You will now have both input and outputs in jack which you can connect to the outputs in ardour as described above, if not done automatically

A strange downside to this aggregate device method is it renders the system volume up/down/mute keys on the Macbook keyboard useless.

Aggregate devices don’t appear in my JP interface list, and they disappear as soon as I quit AMS. I have soundflower installed.

I had the same problem. Then I tried logging in under an administrator account and repeating the process. That worked flawlessly. Hope that works for you too.

The account I use day to day is an administrator account, and I get no help.

Ok here’s what I did just now to get it working using the advice above.

Note: running Qjackctl

First: open apps/utilities/audio MIDI setup. From the menu bar choose audio > aggregate audio device editor. Choose “built-in output” and either mic or line as your input.

NEXT: very important, go to your system preferences and set both your audio in and out to Aggregate Device.

Then: Run jack and choose Aggregate Device as your interface.

FINALLY: Once you’ve launched Ardour and have a recorded track, in the mixer set that tracks out put to: 1+2.

Bingo, you should have playback.

I’m brand brand brand new to this so hopefully it helps. Just giving Ardour a shot since Garageband makes me want to kill things…


utterly frustrated with no sound coming out … tried all you guys tricks … nothing … bummer … would really like to try this software out …

john hartmann
los angeles

what if there is nothing but the ardour tab in the master track output /edit / there are no core audio tabs … anyone ?

john hartmann
los angeles

ok ok ok i got it working … now to play …

i did not have the aggregate device chisen in the jack prefs …

john hartmann
los angeles


I’m new, trying to run Ardour on MacIntel OSX. I installed Ardour following the instructions and initially got no sound. Following the process Lemon says I get it from the master outputs via built-in speakers, but it happens that the sound breaks and stops though Ardour continues running.

The system volume keys went useless too!


I’m another novice getting frustrated trying to set up the audio outputs from Ardour.

I tried the steps above but couldn’t make it work. Also, switching to the Aggregate Device seemed to make my copy of Reason lose it’s output.

I have a Dual Core Intel Mac.

I haven’t a clue what to try now. Any ideas?


I have two apple laptops and also having trouble with the audio outputs