Problem with Audio Export

This is my first time in this forum, so sorry this topic is discussed the seconed time now.

I’ve got a Ardour XP64 on 2,5GHZ, 2GIG DDR, Ubuntu 9.04 with the ubuntustudio package. Latest version of Ardour for Ubuntu as package available 2.noidea

My Problem: I worked first time with Ardour. Before I only worked with Cubase 4 and SX3 for studiosessions. When I tried to bounce my tracks to a stereo-track with the export function, jack had about 30 errors and Ardour crashed completely. I use M-Audio Delta 1010LT. It seems that jack has problems with LADSPA effects during the export. If anybody has an idea how to set jack for my setup, please help me. I want to use it for my studio and finally to get rid of windows, without buying an expensive Macintosh.

Thank You!

Which means Ardour hung up just when I clicked “Export”. I also have a problem when bouncing a single stereo track with effects on it with the “Bounce” function in the sequencer.

Tanks @ Joe. I’m gonna try this asap.

@ Philip: Ardour worked really well until the export problem. And if this is solved it’ s simply perfect. I had so many problems with windows. It happened two times that I wanted to start up for clients, and I had a bluescreen. That’s no longer acceptable. So first I tried Ardour, and it really comes next to protools. If this development goes further on, I don’t see any problem in using it for clients. As long as using analogue effects as well and not only digital effects… And Ubuntu is a lot more stable then windows will ever be.

Flame away… but ubuntu and the word “Studio” should never be in the same universe together. A blunder at best. This is not in response to your post Joe. Great tips for a newcomer. I just think of the hours I wasted hacking and hacking on that gimmick. This linux audio thing could be a lot easier.

Officially the kernel that comes with the 3beta3 release is the recommended one to use. It is a multimedia kernel, and should allow you to do most of what you want to do.

The only limitation the amd64 version of the kernel has, is that is has been compiled with the new firewire stack, which is not supported by FFADO or freebob hardware driver, and my video camera’s raw DV drivers yet.

For this reason I build a couple of kernels, of which I shared the rt11 and rt13 versions on my personal repositories, to alleviate this little problem. It has some other minor issues though.

I am using the 2.6.26 RT i386 kernel on my laptop, and my rt13 kernel on my main system with great results.

Submited by Jhon metrologic

before I finally close this chaotic thread :wink: I have one last question. As I think, there are not that many professional or semiprofessional record studios, who work with ardour, I want to explain other people what ardour is on my studios homepage. Is it allowed to use the ardour logo for advertising? Is there any supportprogramme for studios which work with ardour?
I only want to clearify what ardour exactly is for my clients, and maybe one or more studios will follow in this region.

I’m sure there’s no problem if you put the ardour logo in your site with a direct link to this site. Paul (The Main developer of Ardour) will be the one to correct this or confirm, I used to have a logo of ardour on my site linking directly to this website (I will soon do it now on my blog), I think this will always help Ardour to get more users who will hopefully suscribe and donate.

Also Ardour is open source, so with most open source projects you are free to do almost all you like…

Welcome to the world of unrestricted limits

“I’ve got a Ardour XP64 on 2,5GHZ,” Of course it means AMD XP64…sorry, rough day

Are you using RT kernel?
If not you might want to give it a shot…

what’s the RT kernel? I use the latest ubuntu release as it is downloadable, and the ardour package version from ubuntu studio. I can’t tell you more. I’m new with Linux and not that familiar with the different kernels, sorry. The shot is impossible for the next few weeks.
Jack starts to freak out completely, and ardour does for the first moment nothing, and when I click on anything, ardour hangs up. Which means Ardour hung up just when I clicked “Export”. I also have a problem when bouncing a single stereo track with effects on it with the “Bounce” function in the sequencer. It Bounces the Stereo track to 2 single mono tracks for L&R, thats ok so far, but than there are crackles and noises in it. Without effects it works perfectly on bouncing. I didn’t try it with exporting without effects. But that’s why I think Jack has problems with LADSPA.


Since you are new to linux, here goes:

Best way to run Ardour and JACK is with Realtime Permissions. I also use ubuntu although 8.04 LTS.

In /etc/security you should have a file named limits.conf paste this at the bottom before the “# End of file” line.

@audio - rtprio 99
@audio - nice -10
@audio - memlock unlimited

What that does is that it gives all users that belong to the group “audio” the proper permissions to run Jack in RT mode. Usually you have to check that your user account belongs to that group, usually in ubuntu all desktop users are added automatically to it.

Then reboot and in qjackctl (Do you have qjackinstalled? If not please do) and in Setup check Realtime and you could leave the priority to default for the meantime…

First try with that and see what happens…

You will have to do a lot of reading on how and why you should install the RT kernel, its included in the ubuntu repository, although sometimes it’s just no 100% properly built for audio, but should do the work. I have gotten to the point where I had to learn to compile my own kernel with or withour RealTime support, because the ubuntu maintainers I really don’t think they can tell the difference from their head and their ass…but that’s another story.

You will also have to do some reading in how to configure JACK, remember to use qjackctl. Look for other peoples tips especially here in Ardour forums with your specific Audio card.

Last but not least, you should also in a future learn how to download the RAW source code of Ardour (and maybe any other program you want to use), and compile it yourself, that is if you really want bleeding edge and STABLE versions without depending on the ubuntu repos. I know this sounds very intimidating, but believe me and take my word for it. It will give you a lot more knowledge to become a more advanced linux user and besides it’s not as hard as it looks, actually it becomes so much fun, because the packages in the repositories are just too old, unstable and soetimes don’t have the support for specific thing you might need like LV2 and VST plugins. I think also the export bug you have, is because you are using the Ardour from ubuntu repos, I’ve seen this type of bug before.

Finally, please use the forums here. I mean use the search option, and browse months back. You will see a lot of linux-ardour newbies (I should pop somewhere in the crowd also crying for help and guidance), but you should be able to find all sorts of good info to set you up.

Good Luck and don’t give up. When you get a hold of this things you’ll notice with time you will never go back to windows again. And you can forget about that expensive MAC.


Or do you think it would run better with opensuse? I’m always open for recommendations :slight_smile:

AV Linux 2.0

There’s one problem, it’s available in english only. My english is not that bad, but i don’t think it’s that good. But it looks really nice. Do VST plug ins also work in it?

AV Linux was creted and is maintained by one of the Ardour users here known as GMaq , I myself have not tried it yet, but I am willng to soon. I am sure it’s stable and very functional since he’s another user who probably rants all day about unstable and old repository packages. I guess he just got tired of the same type of issues and decided to do this on his own. His Linux includes the lates kernel (2.6.29) with RT patch, and I believe he probably compiled most of the things and some libs in it.

AV linux is based on Debian, so it’s very similar to ubuntu, actually it should be better, since ubuntu is Debian based, so installing and removing packages should be just the same as in ubuntu, and don’t worry about the language, I’m sure your language should be somewhere in the repos, you could send him an email and ask him some questions.

VST plugins I believe only work if you compile Ardour with the VST=1 flag (Yes you would have to compile it yourself) because VST licensing doesn’t let anyone distribute anything with their implemented code.

OpenSuse is a hell of a nice OS, but you must understand the packaging system is very different, instead of using .deb like debian or ubuntu it uses the RedHat packaging system known as .rpm, this makes it a little harder and rarely breaking your system can happen. I used OpenSuse myself and liked it very much, it can be a little faster, and sexier to the eyes, but for audio production if you wanted to go via rpm based linux I recommend then to use Fedora.

For now maybe as a linux newbie, I would try to stick in a .deb linux, it’s a lot easier to install, remove and even purge residual configurations where in .rpm systems that’s where it gets a little tougher. It’s like trying to figure what dll’s are just taking up space and using the majestic registry editor in windows, just to give you the type of idea

Once you get a nice feeling of linux then you can move to something else like Fedora or SuSe

I’m gonna try it. I have already downloaded the .iso. Maybe this is what I am searching for. Thanks for all the comments and solutions.

One additional question: I stored all my ardour projects on an external hdd. How can I get the new ardour on the new os to realize that I already have some projects?

VST plugins I believe only work if you compile Ardour with the VST=1 flag (Yes you would have to compile it yourself) because VST licensing doesn't let anyone distribute anything with their implemented code.

Dropping in for a quick note while I am procrastinating at work…

This is no longer true. Ardour has switched to using the Vestiage headers, and no longer requires the VST SDK, and Vestiage is compatible with the GPL, allowing packages of it to be distributed post 2.8.


Quick note:

AV Linux 2 comes with the Linux native version of Ardour 2.8 and offers VST support using FST as a separate application or DSSI-VST which will allow VST Plugins to show up as LADSPA plugins within Ardour.

When you install AV Linux you will notice a folder called “Audio Extras” in your user home folder, It contains 2 different Realtime Kernels, the “highmem” Kernel is for systems with more than 4gig of RAM, just install like any .deb package. The “Audio Extras” folder also contains an alternate version of Ardour with built in VST support called ArdourVST. To use The ArdourVST package you must uninstall the existing Ardour package then install the ArdourVST one.

AV Linux 2.0 is English only for the time being.

Is it now allowed to use VST Plugins? They used to be a dangerous thing if you used them for commercial use in record studios with ardour because of different license problems. Are they still only for private use, or can I use them now in my record studio. Because I need VST for my clients. That’s one of the most important points, why I’m still a bit sceptical.