problem to compile

I’d ever used ardour without problem but I made a new installation system (on a slackware)and now I’ve an error when I compile Ardour;

First at the beginnig:

Checking for C header file /System/Library/Frameworks/CoreAudio.framework/Versions/A/Headers/CoreAudio.h… no

and scons stop with: error: possibly undefined macro: AM_PATH_GTK
scons: *** [libs/gtkmm/] Error 1
scons: building terminated because of errors.

excuses me for my bad english language et thanks to help me.

Chapolin (france)

Do you have automake installed? If yes, which version?

Ardour itself doesn’t use auto* tools anymore, but some of the libraries bundled inside still need it.

Did you try to build Ardour 0.99.x or 2.0 (beta or CVS)?

Yes I had automake- 1.9.5 at the beginning but I’d installed automake- 1.6.3 because SWH_Plugins 0.4.7 was need it… (I had 1.9.5 and 1.6.3 on my system because I forgot to desinstall 1.9.5).

I desinstalled the tow automakes and I’d installed automake 1.7.7 and now it walk perfectly!!
(It also work with 1.9.5)

I did try to install Ardour 0.99.2

Thanks a lot for your help :slight_smile:



I’ constantly getting a segmentation fault error message when I run scons. I decided to uninstall 99.2 and tried install 99.3 and got the same error message. Then I had trouble installing 99.2 back, so I installed 99.1 and it’s running fine. Ardour gives me a headache installing but I LOVE IT!..Can anyone assist me in install 99.3?

This is the error messge I’m getting…

& std::basic_string<_CharT, _Traits, _Alloc>::operator=(const std::basic_string<_CharT, _Traits, _Alloc>&) [with _CharT = char, _Traits = std::char_traits, _Alloc = std::allocator]’
libs/ardour/ instantiated from here
/usr/include/c++/3.2.2/bits/stl_iterator.h:726: internal error: Segmentation
Please submit a full bug report,
with preprocessed source if appropriate.
See URL: for instructions.
scons: *** [libs/ardour/globals.o] Error 1
scons: building terminated because of errors.

Do you get that error every time you try to compile? In other words: if you try to “scons” consecutively, do you get the same error at the same point every time?

If so, then you need to upgrade your gcc. If i read correctly and you are infact using gcc 3.2, I strongly recommend you upgrading it to at least 3.4 or better yet 4.0.

If these errors are random, then this issue is something a lot worse. You probably have bad memory in your system. You can use memtest86 to pinpoint where exactly: