Problem to compile ardour2 with BOOST (share_ptr.hpp)


I’m with a Slackware distrib.

1)I’d tried to compile ardour2 with boost_1_34_0 (I’d compile boost with ./configure && make install ) and I’d this error message with the command ‘scons’ to compile ardour2 :

bash-3.00# scons
scons: Reading SConscript files ...
Checking for pkg-config version >= 0.8.0... yes
Checking for gthread-2.0... yes
Checking for lrdf... yes     Checking for libgnomecanvas-2.0... yes
 Checking for gtk+-2.0... yes
Checking for jack... yes
Checking for samplerate... yes
Checking for glib-2.0... yes
Checking for libxml-2.0... yes
Checking for raptor... yes
Congratulations, you have a functioning C++ compiler.
system triple: i686-pc-linux-gnu

detected DIST_TARGET = i686

Checking for usb_interrupt_write() in C library usb... yes
Checking for FLAC__seekable_stream_decoder_set_read_callback() in C++
library FLAC... no
Checking for C++ header file boost/shared_ptr.hpp... no
Boost header files do not appear to be installed.

Then I’d seen where is boost_1_34_0 :

bash-3.00# locate shared_ptr.hpp

And seen in ardour SConstruct :

# boost (we don't link against boost, just use some header files)

libraries['boost'] = LibraryInfo ()
prep_libcheck(env, libraries['boost'])

conf = Configure (libraries[‘boost’])
if conf.CheckHeader (‘boost/shared_ptr.hpp’, language=‘CXX’) == False:
print “Boost header files do not appear to be installed.”
sys.exit (1)

libraries['boost'] = conf.Finish ()

Before ‘scons’ I’d try the command
‘mv /usr/local/include/boost-1_34/boost/ /usr/local/include’ but it doesn’t walk more…

  1. Then I’d try to compile ardour2 with boost-1.33.1 installed with pkgtool the slackware instaler ( boost-1.33.1.tgz) and I’d the same error message : ‘Boost header files do not appear to be installed.’

Then I’d seen where is boost-1.33.1 :

bash-3.00# !lo
locate shared_ptr.hpp

May you help me please ?

I believe you need to load a package called ‘pkg-config’. I run ubuntu so I can do this with apt-get or Synaptic. Not sure how you chase that down with slack.

Good luck!

I just went through all this, so keep posting your errors here (just the tail-end bit) and I’ll see if I can remember what I had to load to get past the same error.



with root:
cd /usr/local/include
ln -s boost-x/boost boost
(where x is the version of your boost mine is 1_35)

now scons to your ardour-2.x directory and youre set to go