Problem: Regions jump behind the playhead

Hey everybody,

I’ve done quite a few projects with Ardour. However, I’ve been encountering strange behaviour for some days now: When stopping the recording of an audio region, the region is automatically moved behind the playhead, though it should remain in front of it. From that point on, I cannot drag&drop the region - nor any other regions in the project. The only way to get it back to where it should be is to select “Move to original position” in context menue. (The regions are not locked, though. And it happens even in newly created projects.)

Is this a bug? Or did I accidentally hit some keyboard shortcut? How can I make Ardour work as it always did, leave regions where I recorded them?

By the way, I am using Ardour 3.5-143-gd98c5f7 on Ubuntu with KXStudio.

You’ve enabled ‘Splice’ mode somehow: you almost certainly shouldn’t have. Set edit mode back to ‘Slide’ (just left of the ‘Smart mode’ button) and all will be well…

Thanks alot, that’s it - problem solved.