problem for record hydrogen in ardour

hi everybody,

new on linux but not in studio, i just love ardour, but have some lil’ problems with it. let me explain :

i run ardour 2.5(3525) from the sid repository i think, with 64studio rt kernell, and hydrogen .93 with midifile from rosegarden 1.7.1. jack is 0.109 2.4.

when i try to rec sounds from hydrogen there’s something i can’t understand :

i start rec at zero >> nothing is rec

i start rec at anyelsetime >> i can see the sound (and play it)

what did i do wrong ?

by the other hand, is it normal i can rec just one track simultaneously, or did i mess something ?

thanks for the reply

I assume you are in jack transport mode. If so, it’s a known bug. It’s not only HG but anything else. I noticed this a long time ago when I tried to record myself (guitar) on a track, starting the transport at 0 in jack transport mode. Just try it, see if you can confirm. Paul Davis said it’s been a long lasting jack bug.

About the one track at a time, I couldn’t say. I never had that problem.

yes jack transport mode in on in ardour. so the tip is to have a marker at 0:0:0:1 ??

do you think one track at a time is a ram problem ?

thank you for the speed in you answer !!

yes, set the start marker at a non 0 value.

I am not sure I got your problem with the multitrack recording issue. Do you mean that your system stops when you try to record many tracks simultaneously ?

no it doesnt stop, but every second or something like a “red” line goes up to down on the screen. this line has the same dimension than one track from up to down, and all tracks are filling in the same red color, following the tape head, without any sound form, and when i stop rec there is nothing on tracks i can see or read

thank you for the value of marker, let’s say it’s a ( start and it rocks the same !

sounds weird. I would think you should try a more recent version of ardour. Maybe you can get one at if you don’t want to compile stuff. Another thing is to update jack as well. But you may want to wait, a new release is about to come out. I am not sure about .deb dependencies though. Have you ever compiled ardour ?

this is fixed in ardour (2.5, i think; but definitely 2.6), but unfortunately our fix requires that hydrogen’s developers “reverse” some code they put into h2 to try to handle ardour’s previously broken behaviour. i am not sure when that will happen.