Problem connecting Zoom h4

Hi Everyone,
I’ve scoured this board as well as others looking for a solution to this problem but nothing has worked. I would really appreciate any help. A month ago, I built a new computer with an eye toward music production. I’m using a Zoom h4 usb mic and, after some initial tinkering, I got it to work. However, (and I’m not sure if this is related or not) but after I used the computer’s mic input to record another instrument the h4 hasn’t worked since (about three frustrating weeks).

The situation now- Pulse recognizes the h4 and its input but I can’t get any audio into Ardour (and I can’t monitor myself with rakarrack like I could before). JACK seems to recognize the h4 since it’s in JACK’s input device menu. I’ve changed the input device to both “h4” and “usb mic” but neither allows me to produce sound.

I promise to donate money to the project if someone can help me out with this! (otherwise, I’ll have to spend that money on a system that works)

Thanks for reading!

I don’t know if this is your problem, but I seem to recall the H4 is “half duplex” - ie. you can use it to record or play back audio, but not both at the same time. Try setting ‘Audio’ to ‘Capture only’ in qjackctl. Good luck.

Thanks for the reply. I tried that but still no luck.

I’m using a Zoom H4n for recording and the laptops sound card for playback. When connecting the USB i select 48K on the Zoom.

Then start the jack server, my Jack Setup has:

Server Path: pasuspender – /usr/bin/jackd Name: default Driver alsa


Priority default
Frames/Period 256
Sample Rate 48000
Periods/Buffer 3
Port Maximum 256
Timeout 2000
Dither None
Audio Duplex
Input Device hw:H4
Output Device hw:0
Latency 16msec

Then start Ardour.

I’m running Ubuntu 11.4 with a realtime kernel. Hope this helps.

Thanks for the reply Graham! Unfortunately, this didn’t work either. Actually, it worked for a minute and then stopped again. Strange…

However, in the live chat room I received some help that worked for me. In case anyone runs into the same problem, here’s what I did.

Plug in H4 and turn on I/O mode (mic or inp1/2)
Before starting of the audio programs, open a terminal and type “alsa_in”
This generates a long response
Keep terminal window open
Then, open and start JACK with the H4 as input device
Then, open Ardour

I don’t think any of the other settings were changed.