Prevent recorded tracks from recording on new tracks

Hi everyone. I made the full switch to Linux about a year ago, and Ardour is the last in several steps to keep me Windows-free forever! So far I love Ardour. The problem I’m having is perhaps simple, but it’s frustrating. I can record a guitar track on track 1 with no problem. I then want to record a second guitar on track 2, but I can’t figure out how to prevent track 1 from also being recorded on track 2. I of course need to hear the previously recorded tracks to play along with, and I’m guessing the problem is in the monitoring aspect somewhere. I’ve tried letting Ardour do the monitoring as well as audio hardware doing the monitoring, and the result is the same. I searched this forum and the net for an answer, but I can’t find anything that gets me past recording one track. I have an Audigy card, and I’m using Qjackctl for my connections. I’ve tried auto-connect and manual connect, but still no joy. I have the outputs routed to the master outputs, and the only input options i have are system capture 1 and 2. Am I missing something here? If you need additional info, please ask and I’ll do my best to give you what you need. Any help will be greatly appreciated. Thanks in advance.

OK, it seems that Jack and Ardour are both doing their jobs beautifully!! Autoconnect is enabled, and I still had the same problem until I started fooling with every button, slider and switch i could find in KMix. I have to have PCM turned up. I need to enable Analog Mix in the input section, then to monitor the track I’m recording, I set the level with Analog Mix in the output section. I found out that my soundcard, a Creative SoundBlaster Audigy only has 2 ins and 2 outs, though I remember seeing more than that when I was using Cakewalk Sonar…anyway, I record using System Capture 1 & 2, and playback using System Playback 1 & 2. A simple adjustment to my system mixer solved the problem. Thanks so much to all who replied and thanks also for the links…more useful info in there as well. I’m sure you’ll hear from me again! Rock on everyone!

edklip, if you set qjackctl with input device to hw:0,2 and output device to hw:0,3 you should have multiple inputs and outputs, not just 1 and 2. I also discovered there is lower latency in my audigy with this setting.

Thanks for the reply. If I turn down or mute PCM capture, then the signal for the new track doesn’t get recorded. I can watch the levels go down and down as I turn PCM recording down. I’m still trying. Any more ideas? Thanks again!

Probably in your soundcard you have PCM recording activated. Check alsa mixer, or your volume manager for your specific sound card, and level it all way down and mute it (in recording tab). You might have to make your mixer gui to show you all your channels, sometimes some are hidden.

I have a very similar problem and for me which seemed to be to do with auto connections appearing out of nowhere; read here:

and here:

I haven’t yet got round to solving it.

Thanks Dave - your tip’s solved my overdub issue, too.

The 1010LT appears to have foldbacks labelled “Multi” in Alsa. I had all these open so simply pulling back Multi and Multi 1 solved my problem.

I was stumped because the errant connections don’t seem to appear in qJackCtl connections. Which is a shame because it’d be nice to patch this channel to monitor headphones.

I’m still workin on this with no success. No matter how I route my ins and outs, I still get the recorded tracks on the new tracks. This is the only thing that is stopping me from being a subscriber. It has to be similar to how I set up inputs and outputs in Sonar, but I just don’t have a handle on it yet. Any insight would be helpful. Thanks again!

There’s a good chance that your soundcard has a “mix” or loopback channel that’s active. That channel will route all audio through itself, so it needs turned off. I’ve run into this problem a few times in Windows, but I suppose it can happen in Linux too.

read this as it may contain some hints for your problem :

joe, I just tried your suggestion, but i still have only system playback 1 and 2, and system capture 1 and 2. In the ardour tab, there are more ins and outs, but I believe those are used for routing audio in and out of other software. Is that correct? Anyway, I’m just happy to have Ardour doing what I want it to do. Looking at a bit of a learning curve, but I just can’t go back to Windows! Thanks!