PreSonus FIRESTUDIO project


(Mato0852) #1

So …

I’m on latest Fedora WorkStation now ;

Again having problems with my PreSonus Firewire Audio Interface .

When I click on the system volume button upright and move the slider … the FIRESTUDIO project’s status LED goes to blue and I can hear the system sounds, but after a few seconds it turns red again . FFADO Mixer shows no DATA for the device .

When I try to start the audio engine either in Ardour or Mixbus they can’t connect to the audio engine, no matter what device / drivers I select .
Tried also to launch QJackCtl separately … ?

Funnily … If I open Cockos REAPER 5 Linux version I get audio output of it and it’s working perfect ():

Click track is playing, playback indicator is moving / scrolling as it should, with no glitches whatsoever .

Now some detailed help here .

/ Toni S .


(Paul Davis) #2

It isn’t clear if you’re using the ALSA firewire driver(s) or FFADO. My guess is that you are using JACK with the FFADO backend, whereas Reaper just ends up using ALSA’s firewire support.

Either stop using JACK entirely, or tell JACK to use the ALSA backend and not the FFADO backend.


(Mato0852) #3

Hi There …

REAPER detects the PreSonus as some DICE-Device !?!
So based on that there’s still some hope the hardware could work generally on Linux also . (:

Just how to set up Jack / ALSA / FFADO ; is my main concern ?

Here’s a link to a screenshot on Google Drive in .png format, which hopefully details how the hardware is detected / set up in / by REAPER .

https://drive.google.com/file/d/1M8t6xdywySjfN8FdeierFT1WbVkX9wON/view?usp=sharing

/ Toni S .


(Mato0852) #4

Did some basic tweaking and I finally got both Ardour and Mixbus working ;
Unfortunately I somehow can’t get lower than 256 buffers … setting it anything below that makes the DAW unable to re-connect to the Audio/MIDI Engine …

Some help here on the last one ?

/ Toni S .


(Paul Davis) #5

You would need to tell us more about what your “basic tweaking” consisted of, and how you’re actually using the Presonus device at this point when running Ardour or Mixbus.


(Simon Florentin) #6

I was using my Presonus FS project for a while with linux before I got a motu AVB ultralite.
There was indeed some tweaking to get it work.

First you need to kill all instances of jack : ps ax | grep jack | grep -v grep | awk ‘{print "kill -9 " $1}’ | sh
Then stop all midi bridge :
a2j_control stop
pkill a2jmidid

Then remove some modules :
rmmod snd-dice && rmmod snd_dice
I think those modules try to get over the firewire bus, so if they are disabled, no more problems!

Next important step is to reset firewire BUS sudo ffado-test BusReset

You can now start jack with :
pasuspender – /usr/bin/jackd -R -dfirewire -dhw:1 -r44100 -p1024 -n3 &

Finally, you can start the midibridge, pulseaudio with the jack sink (if you still want to play system sound through the FSproject)

I’m not sure it’s the right way to do it, but It worked for me! No more red light on the sound card. :wink:


(Chris) #7

@Silhm: what you did was remove the ALSA firewire drivers and use the firewire drivers built into jackd.
The reaper screen shot from TSP0852 very clearly shows Reaper using the ALSA drivers, so on his system at least the ALSA drivers seem to be the reliable drivers to use.

@TPS0852: I’m not sure, but I think FFADO uses the FFADO drivers, not the firewire drivers incorporated into ALSA, so if you are using ALSA you should use something like alsamixer, not FFADO mixer.
Your response was not very clear, did you understand what Paul recommended about making sure you use the ALSA drivers and not the FFADO drivers? When starting jackd you have a choice of drivers, dummy means do not use audio hardware (just route between applications), ALSA means use the linux kernel ALSA drivers, freebob uses the FreeBOB/FFADO firewire drivers to communicate with Firewire devices separately from the kernel ALSA drivers. Likely what happened is you were attempting to use the jackd firewire drivers and the ALSA firewire driver had already loaded, so you had a conflict of two different device drivers attempting to control the same hardware device.

Ardour and Mixbus both have built-in audio backend systems now, so you do not need to use jackd unless you need to route between different applications. Just start the DAW and select ALSA as the audio system to use instead of JACK.