Presonus Faderport

I enthusiastically ordered a Faderport when I read that it was fully supported by Ardour ‘since’ version 4.5. Maybe I get the numbering scheme wrong…, but at least for the current nightly builds, my faderport doesn’t work properly (essentially unusable).
My questions:
Is working out-of-the-box something I shouldn’t expect at the moment but in the near future? (Q: Keeping or returning the Faderport?)
Is someone succesfully using a Faderport with a current build of Ardour 4.4.5xy? (It is at least a possibility, that mine is broken).
Thanks in advance!


There has been a lot of work on the faderport support recently, last commit Dec 14. So it very much is a work in progress. I think Paul may be out of town at the moment, but I would encourage you to get on IRC and chat with him about the experience you are having if you are willing to help get it supported. Sadly I don’t have a faderport to be able to help you much with it here.


Thanks, seablade! That’s about what I thought. A demo (around the 14th?) actually worked perfectly, but the next day - full featured version: very buggy… I tend to assume, that my device is ok, but I have no Windows / Mac to ensure about that.
As I would really like to keep the Faderport (perfect size and set of features), I would gladly help (but don’t know how, yet). Will try IRCing Paul!

But still: maybe someone else owning a Presonus Faderport and running Linux?

OS: Debian 8.2 + kxstudio repositories

I am now back online (UK time), but will be around less continuously than I normally am. When I left the US on the 16th, faderport support was working perfectly, but there were fixes on the 15th (and maybe even on the 16th too). Please email me if I don’t respond on IRC. But do check a current nightly build first, because I have no reason to think that anything is broken after we stopped sending the “Off” command :slight_smile:

Thanks, Paul! I’m checking the nightly builds every day. And maybe I messed something up / routed something wrong / … , but the dates coincide: before the 17th (nightly build, demo version) it worked perfectly, after that it went to buggy. – I will install a debug version today and see what happens…

this is totally interesting for me too like i just checked for some faderports online :wink: on the mixbus webpage they also claimed the faderport is supported from now on…i ll wait a bit longer with the purchase…

It was my own stupidity! Have to use a2jmidid -e.